WordPress.org

Ready to get started?Download WordPress

Forums

dom.com/blog/index.php works dom.com/blog does not (7 posts)

  1. nsidestrate
    Member
    Posted 8 years ago #

    When I access my blog via a URL that only points to the directory the blog is located in, (http://www.nsidestrate.com/blog/) I get the pretty-ish 404 page that comes with my theme. When I specify the full path (http://www.nsidestrate.com/blog/index.php) everything works swimmingly.

    If I gave a totally bogus URL such as http://www.nsidestrate.com/blog/phony_file.html I get a 404 page that comes from my hosting provider (I don't have any htaccess file at the moment).

    The header, footer and sidebar all display fine -- just the area where my posts should be has the 404 message instead.

    I'm about 85% dumb in terms of where to look. It seems to me that it must be loading some of the index.php or it wouldn't load the 404 page from inside my theme. Any ideas?

    Oh yeah, I'm a shiny new blogger under 2.0...

  2. moshu
    Member
    Posted 8 years ago #

    What are the two URIs in your admin > Options > General?

  3. nsidestrate
    Member
    Posted 8 years ago #

    The first (WordPress address) is the directory:
    http://www.nsidestrate.com/blog

    The second (Blog address) is the specific index file:
    http://www.nsidestrate.com/blog/index.php

    (That was a very fast respomse -- I was caught off-guard for a minute)

  4. moshu
    Member
    Posted 8 years ago #

    The gurus say it's not a "healthy" thing to have any of those ending in a filename. Just make it /blog .

  5. nsidestrate
    Member
    Posted 8 years ago #

    I'm in a circular loop. See this previous problem.

  6. moshu
    Member
    Posted 8 years ago #

    In that case I don't know what to say. One thing is sure: WP always has problems with that kind of "tricky" redirects, pointing domains and stuff like that.

  7. nsidestrate
    Member
    Posted 8 years ago #

    I understand. I believe that the redirect thing is driven by an Apache rule I can't see on the server, because it works differently (and better) with http://www.nsidestrate.com/blog/ than it does with http://www.nsidestrate.com/blog

    I suppose I'll just get it hosted as the master domain and move the other domain under it. Thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags