WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] domain.com redirects to domain.com/wp-signup.php?new=domain.com (16 posts)

  1. Angela
    Member
    Posted 2 years ago #

    Actually, I think this is a remnant of my previous fumbling. The issue began yesterday (I think with the addition of another subdomain) when other users are complaining about: 1- they are seeing 310 Too Many Redirects, or 2- they need to register in order to access the website's content (which is nonsense, I've never set that up).

    I've done quite a few things to resolve the issue:
    1- Switch to default permalink structure and switch it back
    2- Disable a plugin that has to do with user registration (that I never needed, it was set up to fix another issue)
    3- Change 'User can register' from '1' to '0'
    4- Change all instances of 'www.domain.com' to 'domain.com' (in both the options table and wp-config.php)
    5- Install this plugin Permalink Fix & Disable Canonical Redirects Pack
    6- change //define( 'NOBLOGREDIRECT', 'www.domain.com' ); to //define( 'NOBLOGREDIRECT', '' );
    7- Clear cache (a million times already)

    Now, here is the thing. 310 is gone, but there are a lot of remnant of the signup.php problem:
    1- Site can be accessed with http://www.domain.com, but not domain.com. If I try to use domain.com, it send me to http://domain.com/wp-signup.php?new=domain.com
    2- I can no longer use any of the links on the WP admin bar because they eventually get redirected to http://domain.com/wp-signup.php?new=domain.com. I can only access them using http://www.domain.com
    3- Can't get into network admin, regardless of the presence of www. All end up redirected to http://domain.com/wp-signup.php?new=domain.com.
    4- Going to any page (such as domain.com/page-name) send me to http://www.domain.com/wp-signup.php?new=domain.com (how funny, just when I thought http://www.domain.com is no longer the problem).
    5- Finally, domain.com/wp-signup.php?new=domain.com is a page with errors whereas http://www.domain.com/wp-signup.php?new=domain.com tells me the following information:

    Greetings Site Administrator! You are currently allowing “user” registrations [comment: bulls***, I disabled user registration long time ago]. To change or disable registration go to your Options page.
    You are logged in already. No need to register again!
    The site you were looking for, http://domaincom.www.domain.com/, does not exist. [comment: where the hell is domaincom.www.domain.com, I don't have it configured ANYWHERE on my site]

    So, I'm going to change all of the domain.com back to http://www.domain.com, see if that fixes any problem. If not, I'm out of luck. Sigh, this is my unlucky wednesday.

    Angela

  2. Angela
    Member
    Posted 2 years ago #

    Update: I made the change from domain.com to http://www.domain.com, problem 1 persists. Problem 4 changes in a quite weird way (so now any page for http://www.domain.com/page-name end up redirected to the home page). And finally problem 5 remains except that domain.com/wp-signup.php?new=domain.com points to http://www.domain.com/wp-signup.php?new=domain.com

    Update 2: I deleted that Permalink Fix plugin, and Problem 4 is resolved. Problem 5 persists, and Problem 1 persists as well (domain.com/page-name get redirected to http://www.domain.com/wp-signup.php?new=domain.com.

    Sigh, wish Tim Berner Lee never put that www there...

    Angela

  3. Double check on the server side you don;t have anything set up to force the www. Some hosts have a wee checkbox.

  4. Angela
    Member
    Posted 2 years ago #

    Can you be more specific about the server side settings? I do have the domain name set up as domain.com (and so on the DNS records, because the server didn't allow me to use www), but it's been like this forever.

    And an alias has been configured to point to http://www.domain.com.

  5. Did you set your site up as www or non when you built it?

  6. And an alias has been configured to point to http://www.domain.com.

    Point to? Or to point hte www to the non-www?

    If you aren;t usrewher ethe server setting is, then ask your host.

  7. Angela
    Member
    Posted 2 years ago #

    Originally, when my site is set up, I believed I didn't use www, and that's what's on the DNS record. There is an server alias for http://www.domain.com. Currently in my database (as it was for about 12 months before this happened), the site URL and home URL are both http://www.domain.com.

    I called my hosting company and they said that the site is running on domain.com, but an alias is created for http://www.domain.com to point to domain.com. But the thing is, if you looked at my previous posts, you would see the kind of mess I'm getting into if I use domain.com in the home and site URL instead.

  8. You should ALWAYS set a multisite up as domain.com

    I think the problem is how your server is aliased. That is, the alias isn't forwarding to non-www correctly. You could do an htaccess redirect to force it, putting in the code like this ABOVE the WordPress section.

    # permanently redirect from www domain to non-www domain
    RewriteEngine on
    Options +FollowSymLinks
    RewriteCond %{HTTP_HOST} ^www\.domain\.tld$ [NC]
    RewriteRule ^(.*)$ http://domain.tld/$1 [R=301,L]
  9. BackuPs
    Member
    Posted 2 years ago #

    There is just an easy solution for this

    http://wordpress.org/support/topic/multisite-440-main-domain-not-working?replies=2

    NOBLOGREDIRECT.

    Turning off Allow users to create a subsite.

    WPMS (wordpress multisite) has a cool feature that new users can create new website. So if they search for helloworld.maindomain.com and this one does not exist they are redirected to some nice signup page for creating the newly blog helloworld.

    However if you do not want this you can disable this and your adviced to put a line in your wp-config.php redirecting users instead of the create new blog screen to the main index of the main domain or any other page within that website..... except the 404. The line to add is define( 'NOBLOGREDIRECT', 'http://maindomain.com' );

    But this means that when a page does not exist and a 404 should be generated the 404 is also never reached. So you 404 is disabled by this instructions. It took me some time to figure this out and to solve it.

    The solutions is pretty simple. Just create a folder in your wp-content called : mu-plugins

    in the mu-plugins you just insert a php file name custom.php with this content. Or whatever name

    <?php
    remove_action( 'template_redirect', 'maybe_redirect_404' );
    ?>
    

    Now what happens is that users who call a blog that not exists get redirected to the root of the main domain to the index.php and really 404's are handled like they should be handled.

    so that one is solved and can be taken of the list.

    Best regards,
    BackuPs

  10. BackuPs - Please don't sign your posts, it's against the rules.

    Also re-read what she said. She already tried noblogredirect. AND it's not 404ing, it's going to her main domain.

  11. BackuPs
    Member
    Posted 2 years ago #

    Where can i read those rules?

  12. Gripping reading those rules, couldn't put it down...

    http://codex.wordpress.org/Forum_Welcome#Signatures

  13. BackuPs
    Member
    Posted 2 years ago #

    Thanks for pointing that out to me. Didn't know that thought i was just being polite on signing it and giving my best regards,..... LOL

  14. Angela
    Member
    Posted 2 years ago #

    Hi,

    I tried the set of rules you gave me, Ipstenu, but it caused a 310 redirect (right back to the beginning of the whole thing). It got me thinking, there must be some sort of redirect in the first place, no?
    Redirect errors are caused by loops, that I know. So basically one rule is trying to direct http://www.domain.com to domain.com (server alias) while the other is redirecting domain.com to http://www.domain.com (your rules). Perhaps should I just remove that server alias, and try to add an htaccess rule to allow typing in of http://www.domain.com (and try to point it to domain.com)?

    Another possible culprit that has come to mind is the W3 total cache. I'm using the plugin and it generates a huge amount of htaccess rules that was previously placed before the #wordpress section of htaccess. I moved it to the bottom, but nothing changes.

    Now the really weird thing is that, even though I disabled blog farms AND user signup. Somehow my WordPress installation is offering it? How did it override that logic?

    Angela

    Edit: in addition, I've also tried your method Backups, to create mu-plugins and insert custom.php. Unfortunately, it still redirects to wp-signup.php?new=domain.com.
    PS: if someone needs to access the back end and take a look, feel free to give me a holler at angela380yn@hotmayl.com (swap y for i).

  15. adminRimma
    Member
    Posted 2 years ago #

    I too mistakenly set up my site as http://www.domain.com instead of domain.com, and finally found this thread, added noblogredirect and have solved my problem for the time being...however, I am concerned about how google is indexing the site now -- should I go in and change the address in google webmaster tools to the non-www version?

    I really wish I had seen this before building my multisite network. Now that I have the main site as http://www.domain.com, I see that it is treated like a subdomain just like all the other subdomains in my network.

    I could rebuild. Is there any SEO issue if I just use the wp-config rule? Do I also have to add the additional file in mu-plugins?

    Thanks in advance!

  16. Angela
    Member
    Posted 2 years ago #

    Just thought I should update the information. Somehow, I went back to change all http://www.example.com back to example.com and now it works fine. Most of it anyway, but still having trouble with that blog farm thing. So thanks for all the inputs, they have been very helpful.

Topic Closed

This topic has been closed to new replies.

About this Topic