WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] domain.com is BLANK but www.domain.com OK - tried htaccess; canonical name prob? (16 posts)

  1. imagiscapeca
    Member
    Posted 6 years ago #

    My whole site was blank - now it's okay if www is used, but it is still blank if www is not used.

    (It's a 500 internal server error, but it displays as blank.)

    As a band-aid solution (not addressing the real problem), I added a rewrite/redirect to .htaccess.

    This worked for imagiscape.ca/blog but not for imagiscape.ca/blog/ (with the trailing slash) or any subsections like imagiscape.ca/blog/caregiving - those addresses still get BLANKS.

    BAND-AID SOLUTION:
    - What can I enter into .htaccess to get imagiscape.ca/blog/ (with the trailing slash) to redirect to http://www.imagiscape.ca/blog/ (with the www and the slash)?
    - By modifying .htaccess, am I compromising the canonical naming system?

    DEEPER SOLUTION:
    - imagiscape.ca/blog displayed properly a few days ago, without any redirect. Why not now? Before I modified .htaccess just now, did something happen to my blog's canonical naming system?

    Previously, I submitted:

    Help, my blog is all blank (not covered in previous support).
    (http://wordpress.org/support/topic/138729)

    My .htaccess file includes:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    # END WordPress
    
    RewriteCond %{HTTP_HOST} ^imagiscape.ca/blog$ [NC] [OR]
    RewriteCond %{HTTP_HOST} ^blog.imagiscape.ca$
    RewriteRule ^(.*)$ http://www.imagiscape.ca/blog [R=301,L]

    I tried several variations including:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^imagiscape.ca/blog$ [NC] [OR]
    RewriteCond %{HTTP_HOST} ^imagiscape.ca/blog/$ [NC]
    RewriteRule ^(.*)$ http://www.imagiscape.ca/blog/$1/ [R=301,L]
  2. imagiscapeca
    Member
    Posted 6 years ago #

    This is still unresolved.

    I may have been mistaken when I wrote that it is an Internal Server Error.

    To re-post the essence of the above (more detailed) post:

    As a band-aid solution (not addressing the real problem), I added a rewrite/redirect to .htaccess.

    This worked for imagiscape.ca/blog but not for imagiscape.ca/blog/ (with the trailing slash) or any subsections like imagiscape.ca/blog/caregiving - those addresses still get BLANKS.

    BAND-AID SOLUTION:
    - What can I enter into .htaccess to get imagiscape.ca/blog/ (with the trailing slash) to redirect to http://www.imagiscape.ca/blog/ (with the www and the slash)?
    - By modifying .htaccess, am I compromising the canonical naming system?

    DEEPER SOLUTION:
    - imagiscape.ca/blog displayed properly a few days ago, without any redirect. Why does it not work now (without the redirect to the www version)? Did something happen to my blog's canonical naming system?

  3. Jerry Gartner
    Member
    Posted 6 years ago #

    Ping the tld and the sub domain (WWW) and make sure they both go to the same place.

  4. imagiscapeca
    Member
    Posted 6 years ago #

    Thanks for the suggestion.

    I just tried it, and yes, imagiscape.ca and http://www.imagiscape.ca go to the same IP address.

  5. imagiscapeca
    Member
    Posted 6 years ago #

    I should clarify:

    imagiscape.ca and http://www.imagiscape.ca work.

    http://www.imagiscape.ca/blog works.

    imagiscape.ca/blog/ and subsections fail.

    imagiscape.ca/blog is redirected so it works, but
    it doesn't work without the redirection (to http://www.imagiscape.ca/blog)

  6. imagiscapeca
    Member
    Posted 6 years ago #

    FYI: This is still not resolved.

  7. imagiscapeca
    Member
    Posted 6 years ago #

    (I have upgraded from 2.3 to 2.3.1, but that did not fix this.)

  8. Samgreen
    Member
    Posted 6 years ago #

    check with your web host.

    It appears to be server config setting.

    There is no php being loaded if the www isn't used. I did a 'show source' in my browser.

    It definately looks like a server config proble that isn't recognizing urls without the www.

  9. imagiscapeca
    Member
    Posted 6 years ago #

    Samgreen,
    Thanks - Your suggestion made me realize I had not clarified that:

    All other sections of my site work with or without www.
    (imagiscape.ca/wiki, imagiscape.ca/reviews, ...)

    It's only the blog that fails.

    This issue was elevated to Level 2 tech support at my host a couple weeks ago, but they seem to think it's a WordPress issue.

  10. Samgreen
    Member
    Posted 6 years ago #

    Hmm. I still think its a web host problem.

    If regular html pages work, but not blogs, it could be their php install/config.

  11. scaturan
    Member
    Posted 6 years ago #

    how about you disable .htaccess (permalinks, etc...), disable all plugins revert to a stock unmodified WordPress theme for now?

    dig reveals http://www.imagiscape.ca as a CNAME for imagiscape.ca.
    and imagiscape.ca pointing directly to 209.205.39.21

    so then the typical Apache <VirtualHost> container would look something like:

    <VirtualHost 208.205.39.21:80>
    ServerName imageiscape.ca
    ServerAlias http://www.imageiscape.ca
    DocumentRoot /usr/home/yourusername/imageiscape.ca/htdocs/
    </VirtualHost>

    how are your WordPress address (URL): and Blog address (URL):
    setup?

  12. imagiscapeca
    Member
    Posted 6 years ago #

    WordPress address (URL):
    http://www.imagiscape.ca/blog

    Blog address (URL):
    same - http://www.imagiscape.ca/blog

    This is the original setup - although I did temporarily change the blog address to http://www.imagiscape.ca for a couple of days while considering migrating.

    Permalink Structure:
    Custom: /%category%/%postname%

    -------

    Disable Plugins?
    I did try this before, and it did not work.
    (I think I recorded this in my previous related topic.)

    -------

    Disable htaccess?
    How? Just remove or rename my htaccess file from imagiscape.ca/blog? And also from imagiscape.ca?
    And set Permalinks to default?

    -------
    Theme - set to default. I did this as per your suggestion. Perhaps it will work when I disable htaccess, but on its own it did not resolve the problem. I returned the theme to my custom theme.

    Thanks,
    Jonathon

  13. imagiscapeca
    Member
    Posted 6 years ago #

    RESOLVED.

    DETAILS:

    Disabling plugins took ages since every action slowly brought up a blank page, which I then had to reload (slow again), so I could disable another, and I had 60 active plugins. I had removed all plugins that seemed possibly not rock-solid, but I had not removed them all.

    Finally I removed them all. (I used phpMyAdmin to empty the plugins field in [a table] in the database - I wrote details elsewhere in the support forum - sorry I don't remember exactly where). Reloading them, the first view of plugins.php had a minor [error] message, but upon activating the first plugin, all was in order. And it was now fast to activate each plugin. (Each page load was close-to-immediate.)

    So,

    RESOLVED.

  14. semajmaharg
    Member
    Posted 6 years ago #

    Could you go into a little more detail about what you did to fix this problem? I seem to have a similar one and it isn't clear what you did to fix it.

    As it happens, I've got a 2.0.3 blog running on the same site as my recently upgraded 2.3.1 one. The former accepts http://www.theliberati.net/drink and http://theliberati.net/drink quite merrily. The latter (.../quaequamblog) doesn't and has all sorts of other problems (including blank pages every time a post or comment is submitted) so I don't think it can be labeled a hosting problem.

  15. imagiscapeca
    Member
    Posted 6 years ago #

    semajmaharg, I deactivated all my plugins and reactivated them. Unless you've got lots and lots of plugins, I would just do it one by one on the plugins admin page. If not, my details are in the forum under ... [plugins field] - I'll find where I posted it if you need me to do so. Let me know.

  16. moshu
    Member
    Posted 6 years ago #

    Clicking on "member" under your name or on your profile you can see all the posts you hacve started (on the right) or participated in (left).
    http://wordpress.org/support/profile/179675

Topic Closed

This topic has been closed to new replies.

About this Topic