WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Domain without www not showing the website (11 posts)

  1. katinkaspirituality
    Member
    Posted 1 year ago #

    The problem? http://www.allconsidering.com/ works. http://allconsidering.com/ is empty. My host tells me it's something to do with Supercache. I usually use 'mod-rewrite', but tried PHP and Legacy caching to solve this as well. Nothing works.

    I'm using the following plugins:

    Akismet
    BulletProof Security (seems to conflict with WP supercache a lot)
    Comment Redirect by Yoast
    Conditional CAPTCHA for WordPress
    Covert Copy Traffic
    FeedBurner FeedSmith
    Greg's High Performance SEO
    Inline Javascript Plugin
    Jetpack by WordPress.com
    OpenHook
    Ozh' Better Feed
    SEO Auto Links & Related Posts
    Simple Yearly Archive
    TinyMCE Advanced
    WP-DBManager
    WP Remote
    WP Smush.it
    Yoast Breadcrumbs

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. katinkaspirituality
    Member
    Posted 1 year ago #

    What's more, uninstalling WP Supercache and deleting the Supercache lines from the Htacces fill didn't solve the problem on this site:

    http://www.bestflutereview.com/ (inaccessible)
    http://bestflutereview.com/ (default URL and accessible)

  3. erinmcostello
    Member
    Posted 1 year ago #

    I have been having the same exact issue and have been trouble shooting it for some time now. I finally was able to trace it to Super Cache as well. I deactivated Super Cache and the problem persisted. Then I re-activated it, changed out of mod-rewrite (to php) then in the Easy tab deleted the cache. Then I de-activated Super Cache again.

    When I tried http://springgunpress.com it actually loaded again and no more blank screen of death. To be clear http://www.springgunpress.com always loaded fine.

    This is a workaround though and I like Super Cache. I would like to be able to reactivate it because now my site is Super Slow instead. :)

    The only active plugin I have in common with katinkaspirituality besides Super Cache is BulletProof Security.

    Any ideas about a fix for this would be fantastic.

    Thanks!

  4. katinkaspirituality
    Member
    Posted 1 year ago #

    I 'solved' this in a similar manner: turned off caching in supercache, cleared the cache (twice) and then turned it back on.

  5. erinmcostello
    Member
    Posted 1 year ago #

    So turning it back on didn't duplicate the original problem?

  6. katinkaspirituality
    Member
    Posted 1 year ago #

    No, but I'm afraid you'll have to keep monitoring it. The combination WP SuperCache and BPS is somewhat tricky. So far every issue I've had with it can be fixed, but it can lead to some weird htaccess content.

  7. katinkaspirituality
    Member
    Posted 1 year ago #

    Unfortunately today my main blog (430 subscribers) was not accessible at either the main blog (with www) or without www. I'm turning off this plugin for now.

    Sure - the problem gets temporarily solved if you delete the cache twice, but it doesn't last.

  8. katinkaspirituality
    Member
    Posted 1 year ago #

    I've gone through all my blogs again (sigh) and find that most are working fine.

    On most that didn't - I could get the non-standard url (with or without www) working through the method outlined above.

    In one case I had to:

    - Go to supercache settings "Easy" tab
    - select "caching off" and update status
    - press "delete cache" twice (!)
    - test redirect, it should work now
    - select "caching on"
    - test again, it still didn't work
    - turned off wp supercache completely - as in deactivate through wp plugins page
    - restored default htaccess code through BPS
    - allowed BPS to recreate it's htaccess codes
    - test again: still no luck (!)
    - add wp supercache commented out line in htaccess through BPS plugin
    # WPSuperCache
    - activate wp supercache (turning it on doesn't seem necessary)
    - to get caching going again: turn it on, don't mess with default settings (The commented out line above means you need to use PHP, not mod-rewrite)

  9. Jason Koning
    Member
    Posted 1 year ago #

    I'm having the same problem on one site, but not another. Both with BPS.
    It would be great to get some acknowledgement from the author, & hopefully a fix so we don't have to stuff around with live client sites.
    I have BPS Pro, so I'll post on their forum & see if they have any suggestions.
    I'll post here once I have feedback.

  10. AITpro
    Member
    Posted 1 year ago #

    Just came across this Thread in my WP Tag travels.

    I have BPS and WP Super Cache with mod_rewrite working perfectly well together on a testing site, but I had to use the BPS Custom Code feature to combine the .htaccess code in order for everybody to be happy. ;) The WP Super Cache htaccess code should come before the BPS .htaccess code as shown in this working .htaccess file in the link below.

    The htaccess file is posted here: http://forum.ait-pro.com/forums/topic/where-is-the-log/

  11. AITpro
    Member
    Posted 1 year ago #

    Super Impressed with WP Super Cache!!!!! AWESOME!!!

    I have benchmarked every single caching plugin and WP Super Cache is the SUPEREST! FASTEST!

    Thanks guys!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic