WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Domain redirection keeps forwarding to signup page? (15 posts)

  1. rapunzel
    Member
    Posted 3 years ago #

    I just installed WordPress 3.0.1 with multi sites so I could make some extra sites off of my main domain. I also have a redirection domain (http://nancydrewgamesfan.com) also set up to redirect to http://girldetective.org only. But every time I browse to it it always forwards me to (http://www.girldetective.org/wp-signup.php?new=nancydrewgamesfan.com) which I don't want it to. I don't even know why that sign up page keeps showing up. And I really don't want it to show up. The last time I fooled around with MU I don't remember it having this sign up page stuff. How can I get it to stop showing up? The extra sites will be maintained by only me and no one else.

    Redirection forwards me to:

    Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.Registration has been disabled.

  2. Do you have a domain mapping plugin working? It looks like it thinks its going to a new domain hosted by WordPress.

  3. rapunzel
    Member
    Posted 3 years ago #

    No I don't have that plugin. Didn't know I needed it.

  4. No, you don't need it. unless you plan on setting up a blog for that domain.

    It's because you've set up a redirect of the second domain. WordPress is looking it up in the database, doesn't find it, so send you to the signup page. it's default behaviour.

    You can put this in to stop the redirect:

    define( 'NOBLOGREDIRECT', 'http://yourdomain.com/' );

  5. dtatem
    Member
    Posted 3 years ago #

    We are new to WP and are having the same issue. Andrea - where do I put the NOBLOGREDIRECT code?
    thanks

  6. In your wp-config.php file, ABOVE the line that says to stop editing there ;)

  7. patty7
    Member
    Posted 3 years ago #

    I am having the same problem...after I put my site up and installed some plug ins I get an (Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.) when I go out to the web to look at my site that is all it says, I can't see my site.

    I seen this post and was very excited to have a solution. Unfortunately I don't see where I should put this code that you have given. I don't see any where that it says "stop editing" here is what I see when I pull up the wp-congig.php file:

    <?php
    /**
    
    Any help I could get would REALLY be appreciated =)
    Patty
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'patty_wrdp1');
    
    /** MySQL database username */
    define('DB_USER', 'patty_wrdp1');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'REMOVED');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = "/";
    define( 'DOMAIN_CURRENT_SITE', 'everythingnmoreworld.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    /* This shit was made multi-site enabled by @link http://jgwebdevelopment.com */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
        define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
  8. NEVER EVER EVER POST YOUR PASSWORDS ON A FORUM ANYWHERE! EVER!!!!!

    Right now, this VERY moment, stop EVERYTHING and go change your damned SQL password. DO NOT ASK WHY JUST DO IT! I'm not kidding. With that password, I can hack your WP install and destroy your database. Change it. NOW.

    Also, please don't post your NONCE and SALTS from your wp-config file, those can be used to crack into your install. We don't want that.

    Yes, I'm shouting at you. This is a dangerous and ignorant thing to do. Learn from it and NEVER make that mistake again.

    In your case, you want to add the noblogredirect stuff above
    /* This shit was made multi-site enabled by @link http://jgwebdevelopment.com */

    However. It looks like you used a plugin to enable multisite. If so, you may run into issues.

  9. patty7
    Member
    Posted 3 years ago #

    I'm Sorry...I didn't realize what I was putting up. I have been trying to get answers to this problem for 3 days, I'm tired, frustrated and new to this.

    I first went to the person who created this multi site plugin Jason Grim and he basically told me to piss off and it was a wordpress problem. I tried to figure out where I was suppose to put the noblogredirect stuff, because it didn't match anything I was looking at. I know nothing about code or HTML.

    Yes I did learn a lot, and no I won't put wp-stuff up again.

    I have no idea how to change my SQL, not a clue. I found it in my cpanel, but I am not sure how to go about it. I found some post on it but I am still not sure where to go or what to do first.

    Again thank you and I'm sorry.

    Patty

  10. Don't worry about being sorry, worry about being SAFE :) you put yourself at risk.

    Anyway, generally I don't recommend using that plugin to set up multisite because of how HARD multisite is. And it really is a major step up from normal, single site, WP. If you're comfortable with WP and can mess with it, then you may be ready to try MultiSite. If you're really super new, then I feel it's an obligation to warn you that you're diving into the deep end.

    If you need help, please post :) we will do our best for ya!

  11. patty7
    Member
    Posted 3 years ago #

    WOOHOO!!!! I DID IT!!!

    I changed my SQL AND IT WORKS...

    I learned a lot in the last 5 hours. Thank You for your support AND concern, I appreciate it. =)

    I have been messing around with word press for about a year, but like I said I have NEVER had to mess with code or HTML (well until tonight after I messed up) The saying is true we really do LEARN from our mistakes. I had to figure out how to change it and I did. I sure was worried. After I read your reply my heart was racing because I new I needed to get it changed fast.

    I am going to give this multi site thing a try...I have to find out if I can do it.

    I am still getting that error message, I have tried deactivating and reactivating plug ins but I still get that error:

    (Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.)

    I don't know why or what's doing it. I sent another post to Jason Grim to see if he can shine some light but I am really not holding my breath.

    Again I really appreciate the time you put in here to give the help we need when we need it.

    Patty

  12. Patty, do some reading over at wpmututorials.com instead.

    you're getting that message becasue wordpress can't find the blog name in the db.

    jason just made that plugin to try and make it easier, but we've found manual setup is the way to go. People learn better that way. ;)

    Also, give us a link to your site. :) It helps.

  13. patty7
    Member
    Posted 3 years ago #

    Thank you Andrea =) I will sure go there and read up.

    my site is http://www.everythingnmoreworld.com

    Patty

  14. patty7
    Member
    Posted 3 years ago #

    Andrea,

    Thank you sooooo much!!! I have been every where and read all I could, and came across the ebook you wrote "Creating a Network in WordPress
    3.0 (and up).

    It is AWESOME, I went through it step by step and checked to make sure everything was like you said it should be...there were a couple of things I changed and POOF!!! My site is up again.

    Thank you so much!
    Patty

  15. you're very welcome! Now tell all your friends. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic