WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Domain name on secondary site getting mangled with Domain Mapping (3 posts)

  1. gregk610
    Member
    Posted 2 years ago #

    Just upgraded a single domain wordpress install to a WordPress multisite installation using subdomains.
    I am using Hostgator, and have setup a wildcard domain on my main site.
    The problem I am having is that when I add an additional site to multisite, and try to access it, it blows up accessing it as second-domain.com. If I access it as second-domain.mainsite.com, it works. But when second-domain.com, and sending it to mainsite's wordpress install, I get a response of :
    The site you were looking for, http://second-domaincom.mainsite.com/, does not exist.
    Why is it mangling the second-domain.com into second-domaincom instead of dropping the .com, and sending second-domain.mainsite.com into wordpress.

    Also, the hypentated second-domain is intentional.

    Any help would be appreciated from any gurus or folks in the know.

    Details: WordPress 3.4.1
    Domain Mapping Plugin 0.5.4.2

  2. On /wp-admin/network/settings.php?page=dm_admin_page, what options did you check? They're numbered, so you can just say the numbers :)

  3. gregk610
    Member
    Posted 2 years ago #

    Mika,
    I have 2,3,4 checked, but the morning after it seems to be working. I think the DNS finally updated properly, and I figured out the difference between the sub-domain sites, and the way that the domain-mapping plugin worked.

    I realized that you put the subsiteb.mainsite.com in the Sites listing and then put the ID, which you can see hovering over the subsiteb like, in the domains plugin with the subsiteb.com information.

    Thanks! It Works!

    Greg

Topic Closed

This topic has been closed to new replies.

About this Topic