WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
Domain name appearing before title in SERP (7 posts)

  1. boybawang
    Member
    Posted 5 months ago #

    In google, bing, and yahoo, the snippet of my home page is displayed with the domain name preceding the title. I don't know why this is, as when I view the preview snippet for my home page using the plugin, there's no domain name preceding it. This only happens on the results for the home page, as the other pages display snippets just fine on the SERP. Any suggestions?

    https://wordpress.org/plugins/all-in-one-seo-pack/

  2. wpsmort
    Member
    Posted 5 months ago #

    Can you provide the URL for your website.

  3. boybawang
    Member
    Posted 5 months ago #

    skipthedrive.com

  4. wpsmort
    Member
    Posted 5 months ago #

    Hi boybawang,

    This is because Google hasn't reindexed your homepage in over a year. You should resubmit your site to Google via Google Webmaster Tools and wait until they reindex it.

  5. boybawang
    Member
    Posted 5 months ago #

    Hi wpsmort -
    Thanks for your quick response.
    Actually, they have reindexed it recently because I did change the title around, and these changes are reflected. I did resubmit via webmaster tools over the last couple of days. Should I try moving the 'Home Page Settings' from the 'General Settings' to the 'All In One SEO Pack' section on the home page itself, and then resubmit to Webmaster Tools?

  6. wpsmort
    Member
    Posted 5 months ago #

    That's interesting because Google SERPS is showing it's not been indexed in over a year.

    The problem is with Google, not with All in One SEO Pack. All in One SEO Pack is correctly outputting your title tag here -

    <title>Remote Jobs, Telecommuting Jobs, Work From Home Jobs | Skipthedrive.com</title>

    Google is just not picking it up and showing that in SERPS. The title that Google is showing (Skipthedrive.com: Remote Jobs, Telecommuting Jobs, Work) does not appear anywhere on your homepage.

    Sorry but this is a Google issue and all you can do is resubmit your homepage to them and see if the reindex your homepage and display your title. Just bear in mind that you cannot force them to display your title, they'll display what they want and all you can do is influence them.

  7. boybawang
    Member
    Posted 5 months ago #

    OK, thanks for looking into this wpsmort. I appreciate it!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.