WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Domain mapping results in redirect loop between the two sites (4 posts)

  1. luftikus143
    Member
    Posted 1 year ago #

    Hi there,

    hours and hours later, and still stuck. Grrr.....

    I've followed all existing tutorials concerning the multisite & domain mapping. Now, I have two sites set up, as folder structure, i.e. site1.de and site1.de/test.

    My site "test" is mapped to "site2.com". In the "domain mapping" I've added the CNAME (don't have an IP) as "site1.de".

    On my host provider's settings, I have set site2.com to be redirected to site1.de (before I've tried it with site1.de/test, but it didn't work either).

    Now, somehow understandably, when I consult site2.com, it's getting redirected to site1.de, but not to site1.de/test.

    When I use a redirect on my host provider to site1.de/test, than there is an infinite loop between the two sites...

    What is wrong? Thanks for any hints!

  2. grosshat
    Member
    Posted 1 year ago #

    It looks too messy. :/

    Always you manage different domains you have to take into account 3 parts of the problem:

    1. WordPress network configuration
    2. HTTP Server (mostly Apache) configuration
    3. DNS configuration

    You must to check each point to be sure of having everything ok. For instance, do you have WordPress configured for serving different domains? Do you have VirtualHost, at Apache level, for each domain? Do you have DNS entries for each domain, pointing to the right IP?

  3. On my host provider's settings, I have set site2.com to be redirected to site1.de (before I've tried it with site1.de/test, but it didn't work either).

    It's not a redirect. it's a domain park (or add-on). What kind of panel does your host use?

  4. luftikus143
    Member
    Posted 1 year ago #

    Hi there. I don't have that cPanel stuff. But I read through a few tutorials once again. And I re-edited the "redirection link", to not point to the URL of my first domain, but to the wordpress path of it. And now it works. Magic. Yeah....! Thank so much.

Topic Closed

This topic has been closed to new replies.

About this Topic