WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Domain mapping only working on root page (7 posts)

  1. adetaylor76
    Member
    Posted 3 years ago #

    Hi,

    I have a main site http://www.adetaylor.co.uk and have now set up some subdomains through WP newtork sites as http://www.subsite.adetaylor.co.uk.

    I now want to map some other domains to these sub sites so they use the new domain rather than the subdomain of my main WP blog.

    I thought I'd cracked it. I've registered the domains, got my host to add them as proaliases and then set up domain mapping in WP. I then went to the root of the new domain and bingo, it it mapped nicely. The only problem is when I then click on a link and it goes back to the sub domain, not the new domain. I was so close, so close!

    Any ideas guys?

    My test sub-site is: http://www.prototype.adetaylor.co.uk
    and I'm trying to map http://www.mango-consulting.co.uk/ to it.

    Thanks in advance.

  2. adetaylor76
    Member
    Posted 3 years ago #

    I was actually using Otto's plugin - I should have mentioned,

    I've actually solved it. I hadn't placed the domain_mapping.php in the right place as every time I did it brought the site down previously. What I hadn't spotted was that I had copied it an not moved it - when it was in two places it didn't work. when it was in the wrong place the redirects didn't work... we're all good now though.

    Cheers

    Ade

  3. studyguidevn
    Member
    Posted 3 years ago #

    Hi,

    I have set up WordPress Multisite and been using domain mapping plugin. Please visit my site: http://www.studyguide.com.vn

    I have done exactly the same as tutorial in http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

    However, when I clicked on the mapped domain, It said: "Apache is functioning normally". I have parked the new domain to my host already but the situation remained unchanged.

    Please kindly advise me.

    Thank you

  4. I was actually using Otto's plugin - I should have mentioned,

    Otto write a tutorial on how to use Donncha's plugin. Just clarifying. :)

  5. adetaylor76
    Member
    Posted 3 years ago #

    Thanks Andrea... Apologies Donncha.

    PS... both of them might want to put it in caps in there docs... 'DON'T leave two copies up there' ;)

  6. studyguidevn
    Member
    Posted 3 years ago #

    Dear all,

    I have set up my Multi-site successfully. Now I can run a number of site:

    My problem was about the host only.

    Thank you guy any way

Topic Closed

This topic has been closed to new replies.

About this Topic