WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Domain mapping not working (6 posts)

  1. rapph
    Member
    Posted 2 years ago #

    I installed WordPress MU Domain mapping plugin.
    I followed the tutorial in wordpress codex.

    Moved the sunrise file
    added the define statement to wp-functions.

    mapped the domain using the ip address method.

    doesn't work, can only find the site under the subdomain address.
    I checked items 2 and 3 in domain options, and nothing works unless I disable primary domains so 5 is checked too.

    I am hosted by Hostgator, and tech support can't help me even though they tried.

    Any advice will be very appreciated...thanks.

  2. wpfranner
    Member
    Posted 2 years ago #

    How are your domains set up in Hostgator cPanel?
    They should be set up as parked domains with "/public_html" or what ever your wp root folder is.

  3. rapph
    Member
    Posted 2 years ago #

    My primary domain is urban-hydro-gardens.com. Before trying to domain map, I had a subdomain best-carpetshampooerreviews.com.urban-hydro-gardens.com
    After a visit to chat support with hostgagor technician, Now I have 2 add on domains:
    *.urban-hydro-gardens.com and bcsreviews.urban-hydro-gardens.com.

    and one addon domain: best-carpetshampooerreviews.com

    and no parked domains.

    Why would they be parked domains? Aren't parked domains considered not in use? Like, you own it but aren't using it right now? There was no mention of parked domains in any of the tutorials I read.

  4. wpfranner
    Member
    Posted 2 years ago #

    Parked domain just means that the domain redirects to your account and from there you can control what happens.

    You can still use your Addon Domain setup if you like. Just make sure that the “Document Root” setting in your Addon Domains administration menu, is set to be the same file path as your WordPress installation (in my case it is “home/public_html” but yours might be different depending on server setup.

    Then you set up the domain mapping in wp network admin panel and you should be good to go.

    This is what I have done on my cPanel server and it works perfectly.

    Remember to make a note of the current domain setup in cPanel in case you need do go back for some reason.

  5. rapph
    Member
    Posted 2 years ago #

    Got it working just as you suggested. I had to remove the domain from addon domains, and add it to parked domains, and all seems fine now. Thanks for your help!

  6. wpfranner
    Member
    Posted 2 years ago #

    Good man! Sure thing:-)

Topic Closed

This topic has been closed to new replies.

About this Topic