WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Domain Mapping is not mapping (16 posts)

  1. glyndavidson
    Member
    Posted 1 year ago #

    I've followed quite a few tutorials on the internet now but still can't get the domain mapping on my multisite to work.

    I have my primary domain (www.belaydevice.co.uk) hosted on fasthosts, and a number of domain names registered with 123-reg that I want to map.

    As of a couple of days ago, this was a fresh install with multisite using directories rather than subdomains.

    Does anybody have experience of the above and can help me get this set up?

    I've already made many attempts to get it working but I'll put those in a follow up post to keep things tidy.

  2. glyndavidson
    Member
    Posted 1 year ago #

    Here's what I've done so far:

    When I used the one click installer in the fasthosts control panel to intsall wordpress, multisite would only allow me to use subdomains and told me this was because it wasn't a new site.

    I've installed the domain mapping plugin and set the IP address to 88.208.252.206

    Interestingly, when I enter the IP address of my server into a browser I get an Apache holding page: 88.208.252.206

    I tried adding a sub domain in my control panel but because multisite uses virtual directories this wouldn't work as it required a subfolder.

    Failing that, in my fasthosts control panel, I tried adding an A record in advanced DNS, to point a subdomain myotherdomain.belaydevice.co.uk to my server's IP address: 88.208.252.206

    Having no joy with subdomains I uninstalled wordpress, downloaded the installer, and did a manual install on the server. This enabled me to use multisite with sub directories instead of subdomains but still no joy.

    I have tried using 123-reg as the DNS, and added an A record to point my new domain to my server IP (88.208.252.206) but this just gives me a page/domain not found error.

    In 123-reg I have tried telling it to use fasthosts as the DNS, and added an A record in 123-reg to point my new domain to my server IP (88.208.252.206) but this just sends me to the Apache page.

    I have tried creating a new web forwarding hosting package on fasthosts for my new domain, gone into advanced DNS, and added a www A record which points my server IP (88.208.252.206) but this just sends me to the Apache page.

    I have tried creating a new web forwarding hosting package on fasthosts for my new domain, and changed forwarding options to point to belaydevice.co.uk but this just serves up my primary domain.

    I have tried a combination of the previous two: I have tried creating a new web forwarding hosting package on fasthosts for my new domain, and changed forwarding options to point to belaydevice.co.uk, gone into advanced DNS, and added a www A record which points my server IP (88.208.252.206) but this just sends me to the Apache page.

    I have six new domains.

    I made each of the changes above to different domain names and allowed them to propagate but still no joy.

    Any help much appreciated.

  3. glyndavidson
    Member
    Posted 1 year ago #

    After posting the above I got the impression that it was the server Ip address that was causing the problem.

    I got this response from fasthosts customer support:

    The domain name belaydevice.co.uk is in our shared hosting server that is why you could not use the IP address 88.208.252.206 to view the website. That would mean that a lot of users or websites are using that same IP address.

    I order for you to access the website without typing in the domain name in a browser, you csn use the test domain assigned to your hosting package.

    http://1062987960.test.prositehosting.co.uk

    Some tutorials suggest using a parked domain but this seems specific to GoDaddy and I can't see a way of creating a parked domain on fasthosts without paying for a separate hosting package which completely defeats the point.

  4. GoDaddy won't let you unless you get a dedicated IP

  5. glyndavidson
    Member
    Posted 1 year ago #

    Thanks for trying to help me but according to everything I've read online it will work with GoDaddy, you just have to park the domain.

    This doesn't seem to help me though as I'm not using GoDaddy, I'm using Fasthosts.

  6. glyndavidson
    Member
    Posted 1 year ago #

    Response from the hosting company:

    "We have tried to verify it from here and it was confirmed that what you wanted to do is not supported in our shared hosting server."

    "You need to have your own server in order for this to be possible and fully working."

    Surely this isn't true if others have managed to get it working on a shared host?

  7. glyndavidson
    Member
    Posted 1 year ago #

    I'm going to do a fresh install and start again.

  8. glyndavidson
    Member
    Posted 1 year ago #

    Have deleted all files off the server except for my child themes

  9. glyndavidson
    Member
    Posted 1 year ago #

    scrap that, best to start completely from fresh. everything gone. database removed.

  10. glyndavidson
    Member
    Posted 1 year ago #

    About to install wordpress 3.4.2 but whilst I'm in the process, before i install the domain mapping plugin, which one should I use?

    there are lots of posts to trunk version etec. otto's page also says not to install through the dashboard but to do it manually, where as others have said to do it the normal way.

    Some say to install the plugin into the wp-content/plugins directory, other say to create a directory called mu-plugins.

    Can anybody tell me which of these is correct please?

  11. glyndavidson
    Member
    Posted 1 year ago #

    WordPress 3.4.2 installed.

    I've added these lines to wp-config.php:

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);

    So the end of wp-config.php now looks like this:

    define('WP_DEBUG', false);
    
    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    
    /* That's all, stop editing! Happy blogging. */
  12. glyndavidson
    Member
    Posted 1 year ago #

    I've confirmed that Apache mod_rewrite is working.

    Looking at the network installation screen in my dashboard, where I choose either sub-domains or sub-directories, it says: "You will need a wildcard DNS record if you are going to use the virtual host (sub-domain) functionality."

    I've checked to see if my control panel supports wild card subdomains and found that it does not. I presume I can set up each subdomain manually so have continued with the install, after all, if I can't then it means I'll have to move to another server.

  13. glyndavidson
    Member
    Posted 1 year ago #

    I have created a directory called blogs.dir in wp-content.

    My wp-config.php now looks like this:

    define('WP_DEBUG', false);
    
    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'belaydevice.co.uk');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* That's all, stop editing! Happy blogging. */

    And my .htaccess looks like this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
  14. glyndavidson
    Member
    Posted 1 year ago #

    A new site has been created (climbingbelay.belaydevice.co.uk) and I've added myself as a user.

    However, when I type http://climbingbelay.belaydevice.co.uk/ into a browser, the URL cannot be found. Obviously this is because I can't use wildcard DNS on my server.

    I've tried to create the climbingbelay.belaydevice.co.uk subdomain in my control panel, but it won't allow me to point it to the root directory.

    I'm going to see if can work arround this by creating a subdirectory called climbingbelayredirect and use .htaccess to redirect to the root.

    Any idea if this will work?

  15. glyndavidson
    Member
    Posted 1 year ago #

    I've created a directory called climbingbelayredirect
    inside this directory i have created a file called index.html which has this code:

    <html>
    <body>
    Subdomain is working
    </body>
    </html>

    When you enter this URL into a browser, the index page is retrieved.
    http://belaydevice.co.uk/climbingbelayredirect/

    I've created a subdomain in my control panel
    http://climbingbelay.belaydevice.co.uk

    Which directs traffic to the subdirectory climbingbelayredirect

    However, when I put http://climbingbelay.belaydevice.co.uk into a broswer, my index page isn't served!!!!

  16. glyndavidson
    Member
    Posted 1 year ago #

    It's Working!!!!!

    Most of the articles I read related to the godaddy control panel, so in the end I left fasthosts and went with godaddy. Setting up on godaddy was straightforward and worked first time.

Topic Closed

This topic has been closed to new replies.

About this Topic