WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] dofollow links on my homepage (8 posts)

  1. Eric
    Member
    Posted 2 years ago #

    Is there an easy way to change my links from nofollow to do-follow on my home page? I know that by default they are all supposed to be do-follow, but for some reason all of mine aren't. See for yourself

    I am running the latest version of WP on a StudioPress theme.

  2. Eric
    Member
    Posted 2 years ago #

    bump* Does anyone know how to fix this? I have no desire to try rooting through tons of code to fix them individually.

  3. Joseph Shaw
    Member
    Posted 2 years ago #

    Just an idea to consider. It may possibly be an option in your theme that you could update to allow links to be followed.

    It's worth a check anyway.

    Joseph B. Shaw

  4. Big Bagel
    Member
    Posted 2 years ago #

    WordPress only adds nofollow tags to your comment section. Your theme or a plugin is responsible for adding them anywhere else. (Perhaps some wayward seo plugin?) Your theme isn't free so I couldn't begin to check if is responsible myself (I doubt it is though). Disable your plugins one by one and switch to the default theme until you can narrow down what is adding them.

    http://codex.wordpress.org/Forum_Welcome
    I'm not a moderator, but please, no bumping or signatures.

  5. Joseph Shaw
    Member
    Posted 2 years ago #

    Sorry, I was just trying to give him a way to reach back to me directly. I'm a bit new to this forum. Thanks for the update.

  6. Eric
    Member
    Posted 2 years ago #

    Thanks for your ideas guys, I will look at my plugins first, pretty sure studiopress wouldn't automatically do this. Also, I think thats my bad Joe, I bumped.. I am also new to this forum, wont happen again.

  7. Big Bagel
    Member
    Posted 2 years ago #

    It's a not a big deal, I just wanted you two to know about the rules because moderators will just remove/alter that stuff without any warning. :)

    Hope you find the culprit. Like I mentioned, I've seen some overzealous SEO plugins do things like this. So, if you have any installed, that might be the place to start.

  8. Eric
    Member
    Posted 2 years ago #

    Alright, just turned off all of my plugins and turned them back on, one by one. Turns out the culprit was a plugin called WordPress Silo Plugin by Dan Raine and Asbjorn Riede. Now that that is gone there is no more rel="nofollow" on any of my homepage links. Boy, that has probably been a thorn in my side for months, thank god it's off now. Thanks again for the advice!

Topic Closed

This topic has been closed to new replies.

About this Topic