WordPress.org

Ready to get started?Download WordPress

Forums

Min and Max Purchase for WooCommerce
[resolved] Does't work at all (8 posts)

  1. Robert Novak
    Member
    Posted 1 year ago #

    Plugin does not work at all with the latest version of Woocommerce 2.0.9

    Any solution?

    http://wordpress.org/extend/plugins/min-and-max-purchase-for-woocommerce/

  2. varktech.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Robert,
    Sorry you're having a problem. I've just re-tested this plugin with WooCommerce 2.0.9 and the 2012 theme, and the plugin functions as normal.

    You could start debugging by checking first to see if there's a JS error happening, as the error messages are injected via JQuery. If that doesn't successfully isolate the problem, you could test by deactivating all other plugins except Woo and Min/max, and switch temporarily to the 2012 theme. Once that's successful, then add 1 plugin at a time and retest until you find the culprit. You can also contact me directly at http://www.varktech.com/support/ .
    Vark

  3. Robert Novak
    Member
    Posted 1 year ago #

    I'm sorry too!

    In debugg mode got this message error: Notice: Undefined index: HTTPS in .../wp-content/plugins/min-and-max-purchase-for-woocommerce/woo-integration/vtmam-parent-cart-validation.php on line 227

    I try to disable all javascript and deactivate other plugins.

    Nothing helped!

  4. varktech.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Robert,
    Line 227 reads:
    if ($_SERVER["HTTPS"] == "on") {$pageURL .= "s";}

    Even though this has been problem-free in 2000+ installations of this and related plugins which have the same code, you've hit the situation which I've found described as follows:

    "Some servers simply don't set $_SERVER['HTTPS'] if the request is non-secure. Some others may set it to 'off'"

    Please replace Line 227 with the following:
    if ( isset( $_SERVER["HTTPS"] ) && strtolower( $_SERVER["HTTPS"] ) == "on" ) { $pageURL .= "s";}

    Hopefully you'll be able to confirm that this repairs the issue, and I'll then commit the code to go up in the next release.

    Thanks,
    Vark

  5. Robert Novak
    Member
    Posted 1 year ago #

    I changed the line and error notice in debugg mode is gone but I still can not make the plugin starts to work.

  6. varktech.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Robert,
    At this point, I'd suggest we take the debug process offline. You can email me directly at vark[at]varktech[dot]com . I'd like to get access to your installation so that we can debug this directly.
    Best,
    Vark

  7. varktech.com
    Member
    Plugin Author

    Posted 1 year ago #

    We've solved the very rare Host Server setup issue. @Robert, thanks heaps for working with me at great length to nail it down. New code will be pushed out with the next release.
    Best,
    Vark

  8. Robert Novak
    Member
    Posted 1 year ago #

    Vark, thanks a lot to you,

    it's been a great pleasure talking to you and I am pleased that we have quickly resolved the problem.

    Keep going!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.