WordPress.org

Ready to get started?Download WordPress

Forums

Optin Revolution: WordPress Popup
Doesn't work with Mail Chimp (17 posts)

5 stars
  1. mngroup
    Member
    Posted 1 year ago #

    I installed the newest version on optin and Mail chimp doesn't work.
    When clicked the link takes the user to mailchimp url that cant be found.

  2. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    @mngroup MailChimp works fine please review the video http://www.youtube.com/watch?v=6hYdCtbGjjM

    All of the issue with the MailChimp integration have been that the variables for U, ID, and Action have been entered in wrong. If your still having problems, send an email to support [at] optinrevolution.com with a login for your WordPress blog and the MailChimp code and we will take a look.

  3. danharding
    Member
    Posted 1 year ago #

    Hi guys,
    I'm having the same issue. I have followed the video, cleared cookies, used private browsing mode, but no matter what I do the form action always stays at: http://mailchimp.us1.list-manage.com/subscribe/post

    Code from popup is below. NOTE: I have taken out my U and ID values.

    I am not using http:// or u= or id= and have no && in the U or ID values.

    Any thoughts?
    Dan

    <form method="post" id="mce_getaccessed" action="http://mailchimp.us1.list-manage.com/subscribe/post" target="_blank"><div style="display:none;"><input type="hidden" name="u" value="***************"><input type="hidden" name="id" value="*************"></div><div style="position: absolute; left: 198px; top: 298px; z-index: 2;border: 1px solid transparent;"><input type="text" name="email" id="email" value="" style="font-size:36px !important;color:#000000 !important;height:67px !important;width:350px !important;background-color:#FFFFCC !important;border:5px solid #666666 !important;"></div></form>

  4. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    @danharding your code is wrong you need to get your form code from MailChimp, I can tell by http://mailchimp.us1.list-manage.com/subscribe/post

    It should be http://YOURNAME.usX.list-manage.com/subscribe/post

    The YOURNAME is unique to you and should not be mailchimp the usX where the X will be a number not usually 1

    I would take a look at the MailChimp tutorial again or find a tutorial of how to create a optin form from MailChimp.

  5. danharding
    Member
    Posted 1 year ago #

    Hi mate,

    That's NOT my code :) That is coming straight out of Optin Revolution...hence my post in this forum :)

    In Optin Revolution i have (*** are mine):

    U: 977a6fa77d1fc828e9775****
    id: 672357****
    Action: goodfunnysmart.us6.list-manage2.com

    I know the right code and I have been trawling the plugin PHP/JS to find where to hard-code it. But to no avail.

    Could you tell me where I can hack it manually to put in goodfunnysmart.us6.list-manage2.com instead of mailchimp.us1.list-manage.com that would be great.

    Cheers,
    Dan

  6. danharding
    Member
    Posted 1 year ago #

    P.S. Optin Revolution version 1.1.2

  7. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    @danharding first always upgrade to the last version which is 1.1.3 the main reason we release a new version is to fix bugs or add functionality, send me a your site url and a temp login and I'll quickly take a look. support [at] optinrevolution.com

  8. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    @danharding been a long night day here, will be around for about 30 mins so if you send now I'll take a look else I'll check it out tomorrow.

  9. danharding
    Member
    Posted 1 year ago #

    I appreciate your help that you offer even after developing such an amazing plugin!

  10. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    @danharding I have tested and it works fine, I notice your using WP Cache but it was turned off so maybe it was the browser caching something. Not sure. Working for me please test again and let me know if you have any problems. It may be worth while testing in another browser like Chrome.

  11. danharding
    Member
    Posted 1 year ago #

    Hi,

    I upgraded about 15mins ago. Didn't work immediately, but just did then (I saw this message as i was about to reply)? So maybe it was a cache thing and the upgrade?

    I apologise for this. Thanks for your help.

    The error I was getting was the same as this guy:

    http://wordpress.org/support/topic/page-you-were-looking-for-has-dissapeared?replies=2

    Cheers!

  12. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    @danharding Had a look there are not details set for Mailchimp make sure you save your settings after entering your Mailchimp details.

  13. danharding
    Member
    Posted 1 year ago #

    Hi again,

    It seemed to work after you tested it which is weird. But the error is back since we have gone live. Details below:

    I am also uncertain about your comments that there "are not detail set for Mailchimp..." as I have the U (****6fa77d1fc828e9775****), id (**23577b**) and ction (*******smart.us6.list-manage2.com) in "Optin Revolution 1" (not Pro...is that a problem) as they have been since before I started this thread.

    Any ideas? *sheepishly* Are you sure you were checking the right site? :)

    The exact problem is:
    1) Popup comes up.
    2) Enter email address
    3) It posts to http://mailchimp.us1.list-manage.com/subscribe/post ("It seems the page you were looking for has disappeared") which is obviously the wrong URL as I have explicitly put the one in above (*******smart.us6.list-manage2.com).

    Cheers,
    Dan

  14. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    Dan did you save your settings after entering them in? Check.

  15. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    If this http://mailchimp.us1.list-manage.com/subscribe/post is coming up is a pretty good indication you did save your settings.

  16. danharding
    Member
    Posted 1 year ago #

    Ok,

    Yeah, three different team members have been in and out of the site over 3wks and for the last two weeks every time I've been in there the settings have been there.

    I just tried turning autosave off, turning the whole plugin off, setting it all back on again. NO luck

    BUT, if I click "preview" the preview popup works fine. When I save then and reload in Chrome Incognito-Mode (to force the popup) it still errors?
    :(

    Dan

  17. Optin Revolution
    Member
    Plugin Author

    Posted 1 year ago #

    Dan,

    When your on the popup 1 there is a big green button in the right, Save Settings. Some setting like adding these details require you to click this button. If you'd like me to take a look send your mailchimp details, blog url and a temp login I'll take a look. Send to support [at] optinrevolution.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.