WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Courseware
Doesn't work in BP 1.7 (12 posts)

  1. vinaysagar4u
    Member
    Posted 1 year ago #

  2. mlopezcol
    Member
    Posted 12 months ago #

    Hello, I found how to make it work with this:
    https://github.com/Courseware/buddypress-courseware/issues/97

  3. christian.j.king
    Member
    Posted 11 months ago #

    Huh? I can't figure out how anything in that helps the Permission Denied error when you click "edit course"

  4. danmylotte
    Member
    Posted 11 months ago #

    if you follow that link and know how to edit the code of the referenced file it will probably fix this. I just struggled with it all morning, though I wasn't getting the permission error. Just a 'page not found.'

  5. AlEstrada
    Member
    Posted 11 months ago #

    Here's the issue that we are referring to:
    https://github.com/Courseware/buddypress-courseware/issues/109

    Hoping to see a fix soon. Courseware is essentially non-existent on BP 1.7. Should have tested in BP 1.7 before updating =(

    Also:
    1. https://github.com/Courseware/buddypress-courseware/issues/116

    2. https://github.com/Courseware/buddypress-courseware/issues/113

    Anxiously waiting for a resolution.

  6. AlEstrada
    Member
    Posted 11 months ago #

    The link provided by @mlopezcol did resolve the issue...
    https://github.com/Courseware/buddypress-courseware/issues/97

    However, this is still a "work-around". Hoping to see an update from Courseware soon.

    Go to:
    /wp-content/plugins/buddypress-courseware/groups/groups.class.php

    Then, go to: line 44

    Add the following:

    if ( !isset( $bp->courseware ) || !is_object($bp->courseware)) {
       $bp->courseware = new stdClass;
    }

    Final result:

    function activate_component() {
       global $bp;
       if ( !isset( $bp->courseware ) || !is_object($bp->courseware)) {
         $bp->courseware = new stdClass;
       }
       $bp->courseware->id = 'courseware';
       $bp->courseware->slug = 'courseware';
       $bp->active_components[$bp->courseware->slug] = $bp->courseware->id;
    }

    I hope this helps.

  7. hkcharlie
    Member
    Posted 11 months ago #

    I can't help thinking if this is all that is required to fix the issues after upgrade to BP1.7, it would have been updated by now, but it isn't.

  8. hkcharlie
    Member
    Posted 10 months ago #

    didn't even have that line of code on line 44 (or anywhere near)

  9. drronsuarez
    Member
    Posted 10 months ago #

    How many people have gotten Courseware to work with BuddyPress 1.7 using the workaround recommended by AlEstrada above in this thread? @Boone can you let folks know if you have any idea about this fix getting formally incorporated into Courseware?

  10. Boone Gorges
    Moderator
    Plugin Author

    Posted 10 months ago #

    Hi folks. I don't have any information beyond what's stated in https://github.com/Courseware/buddypress-courseware/issues/109. You might also check out https://github.com/Courseware/buddypress-courseware/issues/110 for a status update on the project.

  11. Dian Minchev
    Member
    Posted 8 months ago #

    The fix AlEstrada mentioned is working. :)

  12. heathermedick
    Member
    Posted 3 months ago #

    The fix AIEstrada provided us works a treat!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.