WordPress.org

Ready to get started?Download WordPress

Forums

doesn't work even i set all the 777 permissions (14 posts)

  1. Feenix
    Member
    Posted 6 years ago #

    hi,
    have similar problem as described in many topics, but the can't find solution:
    Couldn't write to: /var/www/vhosts/mydomain.com/httpdocs/wp-content/cache/wp-cache-f7836ab2cb818d4ab947c21c672b3b1b.html
    /wp-content and /wp-content/cache/ are set to 777 and the same message appears even if I set 777 permissions up to /var.

    Where is the real problem?

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    php safe mode ?

  3. Feenix
    Member
    Posted 6 years ago #

    hmm.... how to check this?
    phpinfo (); safe_mode shows "On" is this what u mean?

  4. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Yeah, that's it. You'll have to disable that yourself, or ask your administrator to do so. Unfortunately the caching plugin doesn't work when php is in safe mode.

  5. Feenix
    Member
    Posted 6 years ago #

    I've done that - it is the same still, even if I 777 all the directories till root :(

    where can be the problem?

    p.s. on the same server I am using counple of the other cms'es with smarty templating system and related caches and they are working fine.

  6. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Is there anything in your Apache or PHP error logs? Besides that message above..

    I'm not sure why the script couldn't write, unless there's some extra security module (either Apache or PHP) installed.

  7. Feenix
    Member
    Posted 6 years ago #

    I've safe_mode = Off, restarted apache (service httpd restart),
    wp-content is 777
    cache is 777
    but still getting following errors:

    [client xx.xx.xx.xx] PHP Warning: fputs(): supplied argument is not a valid stream resource in /var/www/vhosts/mysite.com/httpdocs/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 195, referer: http://mysite.com/
    [client xx.xx.xx.xx] PHP Warning: fclose(): supplied argument is not a valid stream resource in /var/www/vhosts/mysite.com/httpdocs/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 203, referer: http://mysite.com/
    [client xx.xx.xx.xx] PHP Warning: fopen() [function.fopen]: SAFE MODE Restriction in effect. The script whose uid is 10010 is not allowed to access /var/www/vhosts/mysite.com/httpdocs/wp-content/cache owned by uid 48 in /var/www/vhosts/mysite.com/httpdocs/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 358, referer: http://mysite.com/
    [client xx.xx.xx.xx] PHP Warning: fopen(/var/www/vhosts/mysite.com/httpdocs/wp-content/cache/meta/wp-cache-f7836ab2cb818d4ab947c21c672b3b1b.meta) [function.fopen]: failed to open stream: No such file or directory in /var/www/vhosts/mysite.com/httpdocs/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 358, referer: http://mysite.com/
    [client xx.xx.xx.xx] PHP Warning: fputs(): supplied argument is not a valid stream resource in /var/www/vhosts/mysite.com/httpdocs/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 359, referer: http://mysite.com/
    [client xx.xx.xx.xx] PHP Warning: fclose(): supplied argument is not a valid stream resource in /var/www/vhosts/mysite.com/httpdocs/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 360, referer: http://mysite.com/

  8. Feenix
    Member
    Posted 6 years ago #

    p.s. those apache mods are installed

    LoadModule access_module modules/mod_access.so
    LoadModule auth_module modules/mod_auth.so
    #LoadModule auth_anon_module modules/mod_auth_anon.so
    #LoadModule auth_dbm_module modules/mod_auth_dbm.so
    #LoadModule auth_digest_module modules/mod_auth_digest.so
    #LoadModule ldap_module modules/mod_ldap.so
    #LoadModule auth_ldap_module modules/mod_auth_ldap.so
    LoadModule include_module modules/mod_include.so
    LoadModule log_config_module modules/mod_log_config.so
    LoadModule env_module modules/mod_env.so
    #LoadModule mime_magic_module modules/mod_mime_magic.so
    #LoadModule cern_meta_module modules/mod_cern_meta.so
    LoadModule expires_module modules/mod_expires.so
    LoadModule deflate_module modules/mod_deflate.so
    LoadModule headers_module modules/mod_headers.so
    LoadModule usertrack_module modules/mod_usertrack.so
    LoadModule setenvif_module modules/mod_setenvif.so
    LoadModule mime_module modules/mod_mime.so
    LoadModule dav_module modules/mod_dav.so
    LoadModule status_module modules/mod_status.so
    LoadModule autoindex_module modules/mod_autoindex.so
    #LoadModule asis_module modules/mod_asis.so
    LoadModule info_module modules/mod_info.so
    #LoadModule dav_fs_module modules/mod_dav_fs.so
    LoadModule vhost_alias_module modules/mod_vhost_alias.so
    LoadModule negotiation_module modules/mod_negotiation.so
    LoadModule dir_module modules/mod_dir.so
    LoadModule imap_module modules/mod_imap.so
    LoadModule actions_module modules/mod_actions.so
    #LoadModule speling_module modules/mod_speling.so
    LoadModule userdir_module modules/mod_userdir.so
    LoadModule alias_module modules/mod_alias.so
    LoadModule rewrite_module modules/mod_rewrite.so
    #LoadModule proxy_module modules/mod_proxy.so
    #LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
    #LoadModule proxy_http_module modules/mod_proxy_http.so
    #LoadModule proxy_connect_module modules/mod_proxy_connect.so
    LoadModule cache_module modules/mod_cache.so
    LoadModule suexec_module modules/mod_suexec.so
    LoadModule disk_cache_module modules/mod_disk_cache.so
    LoadModule file_cache_module modules/mod_file_cache.so
    LoadModule mem_cache_module modules/mod_mem_cache.so
    LoadModule cgi_module modules/mod_cgi.so
    LoadModule security_module /usr/lib/httpd/modules/mod_security.so
    LoadModule logio_module /usr/lib/httpd/modules/mod_logio.so
    #LoadModule jk_module /usr/lib/httpd/modules/mod_jk.so
    LoadModule frontpage_module /usr/lib/httpd/modules/mod_frontpage.so

  9. Jeremy Clark
    Moderator
    Posted 6 years ago #

    [client xx.xx.xx.xx] PHP Warning: fopen() [function.fopen]: SAFE MODE Restriction in effect. The script whose uid is 10010 is not allowed to access

    This is stating that safe mode is still on.

  10. ericdano
    Member
    Posted 6 years ago #

    Hmm, I can't get supercache to serve up a page at all. If it is on and compression is enable, nothing happens. All pages are served dynamically. If the compression is off, then WP-Cache serves them up.

    I think Supercache worked a couple of versions ago for me, but .4 and this latest one don't work.

    Really thinking about going back to just WP-Cache......which seems to work without all this hassle.

  11. Feenix
    Member
    Posted 6 years ago #

    WOW! seems, that I've found a part of the problem:

    safe_mode = Off on "master value"
    but
    safe_mode = On on "local value"

    I will take a look, how to disable on local...

  12. Jeremy Clark
    Moderator
    Posted 6 years ago #

    you can try adding this to your .htaccess file in your wordpress directory
    php_value safe_mode off

  13. Feenix
    Member
    Posted 6 years ago #

    IT WORKS! I see /cache directory full of html files

    I have missed one of the .include files...

    <IfModule mod_php5.c>
    php_admin_flag engine on
    php_admin_flag safe_mode off
    php_admin_value open_basedir "/var/www/vhosts/mysite.com/httpdocs:/tmp"
    </IfModule>

    And it works even with the safe_mode = Off in "master value" (globa php.ini)

    THANK YOU!

  14. Donncha O Caoimh
    Member
    Posted 6 years ago #

    That's great!

Topic Closed

This topic has been closed to new replies.

About this Topic