WordPress.org

Ready to get started?Download WordPress

Forums

Live Stream Badger
[resolved] Doesn't show the streams :( (7 posts)

  1. huntersc2
    Member
    Posted 1 year ago #

    Hey
    Maybe I am too stupid for this plugin but it doesnt work for me as a widget... :(

    I got the same problem as this guy had http://wordpress.org/support/topic/dont-show-the-streams?replies=6 but i couldnt solve it.

    I've installed Widget CSS Classes and tried some widget_ classes.

    http://huntersc2.bplaced.net/

    [livestream...] stuff works fine

    hope you can help me

    http://wordpress.org/extend/plugins/live-stream-badger/

  2. Tadas Krivickas
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Cannot open your page, "Sorry, access forbidden, error 403.".

    Tadas

  3. Tadas Krivickas
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I was able to reach your page now.
    It seems the issue is different since I cannot see the status output in your page. The other guy only had CSS issues because of the theme, while the stream status actually existed in HTML output (view page source), which is not the case for your page.

    I will check what could be the issue. In the meantime, could you lend a hand and try to get me debug mode output as described in this thread?

  4. huntersc2
    Member
    Posted 1 year ago #

    actually, there has no debug.log file been generated :(

  5. Tadas Krivickas
    Member
    Plugin Author

    Posted 1 year ago #

    Can you install Core control plugin?
    Then enable all modules under Tools > Core control. Also enable logging under External HTTP Access logger. Go to the site then and refresh a few times. And then send me screenshots of all the tabs in Core Control, please.

  6. huntersc2
    Member
    Posted 1 year ago #

  7. Tadas Krivickas
    Member
    Plugin Author

    Posted 1 year ago #

    Yep, and you found the cause already. :)
    In External HTTP Access it says that none of the external HTTP access transports are available (cURL, Streams, fsockopen).

    Which, shortly speaking, means that you can't make external HTTP requests using WordPress HTTP API.

    What you could do is ask your hosting provider to allow such capability. Turning it off does not really increase any security and turning it on does not make it insecure either if configured properly.

    Another option would be to change hosting provider - there are plenty of them who will provide not such restricted hosting options.

    I will add transport capabilities' check to the general plugin health check upon activation - to avoid such situations.

    In upcoming versions I might add [client-side] JS based stream status, but not sure as of this moment - it's not as reliable as on server side.

    Sorry for inconvenience,
    Tadas

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.