WordPress.org

Ready to get started?Download WordPress

Forums

WP Minify
Doesn't seem to work (8 posts)

  1. Strictly Software
    Member
    Posted 11 months ago #

    Hi

    I installed your plugin on two of my sites recently.

    Both sites are on the same server.

    One site is behind cloudflare.

    Both sites use WP Super Cache with the same settings.

    These are the main WP Super Cache settings

    Use mod_rewrite to serve cache files
    Don’t cache pages for known users
    Don’t cache pages with GET parameters. (?x=y at the end of a url)
    Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated
    Extra homepage checks. (Very occasionally stops homepage caching) Only refresh current page when comments made.

    I also have WP Widget Cache enabled.

    Settings

    Enable Widget Cache - TRUE
    Enable auto expire options (e.g. When categories, comments, posts, tags changed) - TRUE
    Enable vary by params options (e.g. Vary by user levels, user agents) - FALSE

    The WP Minify settings are these:

    Enable JavaScript Minification - TRUE
    Enable CSS Minification - TRUE
    Enable HTML Minification - TRUE
    URIs on which WP-Minify parsing will be disabled (line delimited)
    /
    Cache expires after every 900 seconds
    Use "pretty" URL" - TRUE
    Place Minified JavaScript in footer - FALSE
    Force all JavaScript/CSS calls to be HTTPS on HTTPS pages - TRUE
    Automatically set your Minify base per siteurl setting (recommended) - TRUE

    The site behind cloudflare is working fine, I can see compressed HTML and JS/CSS.

    However the site NOT behind Cloudflare doesn't seem to be minifying anything. This site is http://www.ukhorseracingtipster.com

    I have tried turning all the plugins off, then back on.
    Leaving just Minify on and turning WP Super/Widget cache off and various alternatives.

    I have tested it logged in, not logged in, logged in with ?1=1 in the URL to force an un-cached WP Super Cache page and so on.

    I am to a loss as why the plugin is not working as it WAS working the other day.

    All I did was remove one other plugins from my site which was the AddThis plugin as I am now using Jetpack for the social media icons.

    As I said the site is http://www.ukhorseracingtipster.com however I have told your plugin NOT to minify the home page as I added / to the list of URLs to ignore (as you can see from the settings), plus I need that page to be dynamic for obvious reasons.

    Check out this page and see how its not being minified.

    http://www.ukhorseracingtipster.com/2013/08/mr-moet-in-melbourne-ahead-of-makybe-diva-stakes-return/

    or this page

    http://www.ukhorseracingtipster.com/2013/09/hannon-targets-reef-success/

    I have viewed the source, generated source but can see no Minification going on.

    I have turned on the debug option and installed FirePHP but get no errors.

    I can see nothing in the console apart from a bad gateway error for:

    NetworkError: 502 BAD_GATEWAY - http://log.pinterest.com/?via=http%3A%2F%2Fwww.ukhorseracingtipster.com%2F2013%2F08%2Fmr-moet-in-melbourne-ahead-of-makybe-diva-stakes-return%2F&guid=pECvwanohP8z&type=pidget&callback=PIN_1379588519065.f.callback1"

    Nothing to do with your site.

    I am at a loss to why your plugin has stopped working.

    I have de-activated, deleted, re-installed, re-named folders and so on.

    The plugin all has the right permissions on the config and cache files.

    I have tried giving them the highest permissions (on the cache folder 777) but that doesn't work either.

    I cannot seem to find a way to either find out what is causing the problem or see in the source OR console reasons for it not to work.

    Any help diagnosing this problem would be great.

    I do know PHP so I can edit files if needed.

    I found that having your plugin working on my other site, along with WP Super Cache AND behind CloudFlare has really sped it up so I would like the same speed for this site if possible.

    Thanks for any help you can provide!

    http://wordpress.org/plugins/wp-minify/

  2. Strictly Software
    Member
    Posted 10 months ago #

    Hi

    I think I have found the problem but I need a solution from you on how to ignore minification on just the home page.

    I have tried putting

    /
    /wp-content/themes/[theme_name]/home.php
    /home.php
    home.php
    /index.php
    index.php

    in the "URIs on which WP-Minify parsing will be disabled (line delimited)" box but this seems to make the plugin ignore minification on ALL pages in the site.

    If I empty the box however it works BUT on the homepage I get a JavaScript error:

    Uncaught SyntaxError: Unexpected token }

    On line 219 of one of your cached files.

    /wp-content/plugins/wp-minify/cache/77106b9c39d58c27fca7501d1f978efc.js?m=1381510270

    The code on that line is (and I have included the lines before and after)

    [line 218] function denc(a){if(typeof(decodeURIComponent)=="function"){return decodeURIComponent(a)}else{return unescape(a)}};jQuery.noConflict();jQuery('ul.superfish').superfish({delay:300,animation:{opacity:'show',height:'show'},speed:'fast',autoArrows:true,dropShadows:false}).find("> li > ul > li:last-child, > li > ul > li > ul > li:last-child, > li > ul > li > ul > li > ul > li:last-child").addClass("last-nav-element");jQuery(".js #featured, .js div#tabbed").css("display","block");jQuery("ul.navigation > li > ul").prev("a").attr("href","#");var $featured_content=jQuery('#featured_content'),$tabbed_area=jQuery('div#tabbed'),$controllers=jQuery('div#controllers'),$comments=jQuery('ol.commentlist');et_search_bar();if($featured_content.length){$featured_content.cycle({timeout:3000,speed:300,cleartypeNoBg:true,prev:'a#left_arrow',next:'a#right_arrow',pager:'div#controllers',fx:'fade'});var controllersWidth=$controllers.width(),controllersLeft=Math.round((960-controllersWidth)/2);if(controllersWidth<960)$controllers.css('padding-left',controllersLeft);};if($tabbed_area.length){$tabbed_area.tabs({fx:{opacity:'toggle'}});};if($comments.length){$comments.find(">li").after('<span class="bottom_bg"></span>');};<!----Search Bar Improvements---->function et_search_bar(){var $searchform=jQuery('#header div#search-form'),$searchinput=$searchform.find("input#searchinput"),searchvalue=$searchinput.val();$searchinput.focus(function(){if(jQuery(this).val()===searchvalue)jQuery(this).val("");}).blur(function(){if(jQuery(this).val()==="")jQuery(this).val(searchvalue);});};;WPGroHo=jQuery.extend({my_hash:'',data:{},renderers:{},syncProfileData:function(hash,id){if(!WPGroHo.data[hash]){WPGroHo.data[hash]={};a=jQuery('div.grofile-hash-map-'+hash+' span').each(function(){WPGroHo.data[hash][this.className]=jQuery(this).text();});}
    <strong>[line 219 - erroring in console]</strong> WPGroHo.appendProfileData(WPGroHo.data[hash],hash,id);},appendProfileData:function(data,hash,id){for(var key in data){if(jQuery.isFunction(WPGroHo.renderers[key])){return WPGroHo.renderers[key](data[key],hash,id,key);}
    <strong>[line 220]</strong> jQuery('#'+id).find('h4').after(jQuery('<p class="grav-extra '+key+'" />').html(data[key]));}}},WPGroHo);jQuery(document).ready(function($){Gravatar.profile_cb=function(h,d){WPGroHo.syncProfileData(h,d);};Gravatar.my_hash=WPGroHo.my_hash;Gravatar.init('body','#wpadminbar');});;var WPCOMSharing={done_urls:[],get_counts:function(url){if('undefined'!=typeof WPCOMSharing.done_urls[WPCOM_sharing_counts[url]])

    Therefore I NEED to ensure your plugin IGNORES my homepage.

    All other pages work. So I need JUST the homepage to be excluded.

    The full path of the homepage is:

    /wp-content/themes/minimal/home.php

    So what do I put in the box to exclude JUST that page/file from your minification process without blocking minification on ALL pages which a / seems to do?

    If I could fix this then it would be working fine!

    Any help would be much appreciated.

  3. Strictly Software
    Member
    Posted 10 months ago #

  4. Strictly Software
    Member
    Posted 10 months ago #

    If anyone else is having a similar problem I have used Better WordPress Minify > http://wordpress.org/plugins/bwp-minify/ and this seems to work and lets me ignore my homepage with just

    /

    No JS errors, and all internal scripts/CSS combined.

    So it's a solution but I would like the HTML compressed if possible as well so a fix for WP Minify would be nice.

  5. damoncloudflare
    Member
    Posted 10 months ago #

    Just a note that you don't want to turn on CloudFlare's Minify options and then ones in a plugin as well. You will eventually have a conflict of sorts running more than one minify opiton on the site.

  6. Strictly Software
    Member
    Posted 10 months ago #

    Hi

    I'm not sure if you caught this but I said I had 2 sites on a server, one was behind Cloudflare, one wasn't. It was the site NOT behind cloudflare that was using WP Minify that wasn't working (or isn't anymore). The site behind Cloudflare is using WP Minify and WP Super Cache and working perfectly fine together.

    Also it would be great if WordPress or Minify plugins had options to add async to their SCRIPT tags to stop blocking as well as loading less files etc.

    Cloudflare uses type='text/rocketscript' which basically does the same thing and is great as the page loads really fast and then the JS widgets just pop in when they are ready - especially great for 3rd party hosted widgets.

    Anyway I have moved from WP Minify to another minification plugin now and it works fine although it doesn't minify the HTML.

    So it's a shame I cannot get WP minify working as it was doing a good job and I did find that when WP Minify was working, that this plugin AND WP Super Cache was actually faster than using Cloudflare and a caching plugin! However I have had to move on now.

    Thanks

  7. Kimberly
    Member
    Posted 7 months ago #

    guess im too late to give my 2cents

  8. Strictly Software
    Member
    Posted 7 months ago #

    No, you are perfectly welcome to give your two cents!

Reply

You must log in to post.

About this Plugin

About this Topic