WordPress.org

Ready to get started?Download WordPress

Forums

Blogger Importer
Doesn't recognize comments (6 posts)

  1. Zoe Rooney
    Member
    Posted 1 year ago #

    The posts all imported correctly, but comments are showing as 0/0 no matter what I do (re-authorize, etc.) I can get the comment to start to import at WordPress.com but am having other problems there, probably due to the volume o comments (around 180k). All the posts imported correctly but I'm stuck on what else to try for the comments.

    Any suggestions?

    http://wordpress.org/extend/plugins/blogger-importer/

  2. Workshopshed
    Member
    Plugin Author

    Posted 1 year ago #

    I was just having a look at the code to see what the maximum value it should be able to cope with.
    The comments is an integer value so it should be able to load upto 2147483647

    You could have an experiment with the "OAuth Playground" to see if that highlights any issues.

    http://googlecodesamples.com/oauth_playground/

    The comments can be found at

    http://www.blogger.com/feeds/blogid/comments/default

    Where blogid needs to be replaced with the ID of the blog.

  3. Zoe Rooney
    Member
    Posted 1 year ago #

    I'm able to get the comment feed using the OAuth Playground but I'm not really sure how that helps me figure out why the importer still shows 0/0 for comments?

  4. Workshopshed
    Member
    Plugin Author

    Posted 1 year ago #

    Zoe,
    the comments url used by the plugin is subtly different. You need a couple of parameters on the end.

    https://www.blogger.com/feeds/blogid/comments/default?max-results=1&start-index=2

    Where blogid is replaced.

    Assuming that also returns without error then we can have a look at the count that it's trying to retrieve. If you look in the results of the comments, just below the author section you should see something like this.

    <generator version="7.00" uri="http://www.blogger.com">Blogger</generator>
    <openSearch:totalResults>8</openSearch:totalResults>
    <openSearch:startIndex>1</openSearch:startIndex>
    <openSearch:itemsPerPage>25</openSearch:itemsPerPage>

    In my example there are just 8 comments to process.

    It could be that the values in your feed are causing the plugin a problem?

  5. Zoe Rooney
    Member
    Posted 1 year ago #

    Using that URL, I do see the correct number of comments in the OAuth Playground (just under 187k), so that doesn't appear to be the issue.

    I'm happy to continue troubleshooting as I'd love for this to work in the future, but just FYI I've done a ton of manual processing on this particular blog and have got it all just about converted and uploaded.

    Thanks,
    Zoe

  6. Workshopshed
    Member
    Plugin Author

    Posted 1 year ago #

    I've checked a few other things and I've no further ideas I'm afraid.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.