WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] Doesn't do bulk with WPMUDEV's own domain mapping plugin on Multisite (10 posts)

  1. Tevya
    Member
    Posted 5 months ago #

    It sends the subdomain URL, instead of the mapped domain, then fails.

    http://wordpress.org/plugins/wp-smushit/

  2. Tevya
    Member
    Posted 5 months ago #

    I realized I can just go to the domain, then run it from there, and it works. However, it would be nice if it recognized domain mapping and ran it from the domain without having to go to the admin at the plain domain's URL, rather than the subdomain.

  3. David
    WPMU DEV Support Staff
    Posted 5 months ago #

    Hi @Tevya,

    I hope you're well today! :)

    Thanks for posting this. To be sure I understand you correctly, you're able to use the smush.it features on:

    sub-domain.multisite-domain.com

    But you can't use the smush.it features on:

    mapped-domain.com

    Where mapped-domain.com is mapped to sub-domain.multisite-domain.com.

    Is that correct?

    I can't easily spot anything in the code that might be an issue so I'll check with the team on it.

    Thanks for mentioning this. We'll have a look! :)

    Thanks,
    David

  4. Tevya
    Member
    Posted 5 months ago #

    No, the opposite. As the super admin, I usually navigate sites via the subdomains: sub-domain.multisite.com/wp-admin/ and I tried running the bulk smushit from there. It doesn't work, responding that the images have to be on the same site, and indicating the mapped domain: mapped-domain.com. So if I just go to mapped-domain.com/wp-admin then it works. Which is fine. It would be nice if it just passed the mapped domain, since that seems to be what's required. But it does seem to work.

    However, it appears to be getting hung-up on a specific file: http://helamangallery.com/2010/miscellany/helamangallery-com-wallpaper/attachment/helamangallery-com-logo-wallpaper-01-2/

    Everything before that was smushed by the bulk option. Nothing after is is smushed. Even if I try to smushit by itself, by clicking "Re-smush" in the media gallery, it goes to a 404 error page. Could it be the "." in the filename? Or perhaps that it's a PNG? I can't figure it out, but would like to bulk smush all the files that come after it, but it seems to be breaking the process. Is my only option to kill it and try again?

  5. Tevya
    Member
    Posted 5 months ago #

    I deleted it and tried again, and it ran until it found another of the same image: http://helamangallery.com/files/2010/04/helamangallery.com-logo-wallpaper-01.png then it died again.

    But I discovered that you can use the bulk options to only run the files you select through. Since there's only 1.3 pages left of images (20 per page), I'll just do it that way. It's easy enough.

  6. Tevya
    Member
    Posted 5 months ago #

    Well... never mind. That doesn't appear to work. It just reloads the media library page I'm on and retains the same errors (from trying on the subdomain) in the Smush.it column. I'll just do them one by one, but there does seem to be something broken with using it from the Bulk Actions dropdown.

  7. Tevya
    Member
    Posted 5 months ago #

    Sorry for all the updates.

    I just realized there's a setting for the subdomain/domain thing in the settings. I think if I uncheck "Enforce image URL is same as Home" then it'll on the subdomain? I'll try when I get a chance....

    Would like to know why bulk actions dropdown doesn't work though.

  8. David
    WPMU DEV Support Staff
    Posted 5 months ago #

    Hi @Tevya,

    After looking into it more, I did notice that option in the plugin code. Could you let me know how that goes before proceeding?

    Thanks,
    David

  9. Tevya
    Member
    Posted 5 months ago #

    I tried it on another site, and it worked just fine. So as long as you uncheck that option, it works on the subdomain, instead of the mapped domain. :)

    I have a feature request/suggestion, but I'll create a new thread for that.

  10. David
    WPMU DEV Support Staff
    Posted 5 months ago #

    Hi @Tevya,

    Glad that sorted it. I was happy to see the option when looking through the code but glad you spotted it before I posted back here.

    I think we've already gotten to your feature suggestion but I'll have a look there in case. :)

    Cheers,
    David

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.