WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Does W3 Total Cache Add to the Server Load? (Website Suspended) (5 posts)

  1. Bane Unreinen
    Member
    Posted 4 years ago #

    For now, I will not be naming my website host. I have been with them for almost 3 years, and only recently have there been any issues outside of expected ones.

    Today, however, one of my larger sites was suspended and my website host is stated that 'Seems your site was causing an extreme load on the server'.

    I have the same amount of traffic, slightly less actually, and the only change to the site was the addition of the W3 Total Cache plugin.

    I am wondering if anyone else has had a server load spikes from this plugin or other similar issues.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. vishwaswish
    Member
    Posted 4 years ago #

    i don't no about w3-total cache. But long back i also faced the same problem turned out be SPAM. See your website/server stat and look whether anyone is using more bandwidth then need. For me it turned out most of my bandwidth where used by particular ip ~40GB, after blocking them my site was normal. Try contacting your host and check for any type of bugs or gilch.

  3. Frederick Townes
    Member
    Posted 4 years ago #

    @Bane Unreinen, were you changing your minify settings often and clearing cache to attempt to configure it? Minify is the most resource consuming library in the plugin (but it does not need to run often). Or did you set your cache methods to memcached without having memcached installed (this is a common mistake). For shared web hosting environments, use disk enhanced for page cache and disk for database and minify. If you still have problems then your server is likely underpowered for database caching and use of minify or both (without custom settings or at all).

  4. Bane Unreinen
    Member
    Posted 4 years ago #

    Hello Frederick.
    I was changing the minify settings & clearing cache when the issue occurred. I have moved the site to another machine and have had no problems since.
    I apologize for the long wait time to your response; work work work :)

    ~Bane

  5. Frederick Townes
    Member
    Posted 4 years ago #

    Ok @Bane Unreinen, I'm glad to know that it was not the normal operation of the plugin causing the issue. Thanks for confirming. There will be some optimizations applied to minification before the final release.

Topic Closed

This topic has been closed to new replies.

About this Topic