WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Does the image editor need to be "turned on" somehow? (11 posts)

  1. thetanooki
    Member
    Posted 4 years ago #

    For the record, I'm using WordPress 2.9.2, but the pull down menu only went up to 2.9.1.

    Anyway, I've got two blogs - my main website that I've been using since early 2007 and has WordPress upgraded many times since. The other is a test blog I use to try out new themes, plugins, and other features for my site, and it was a fresh install of 2.9.2.

    The image editor was working perfectly fine on the test site - I'd upload an image, the "Edit Image" button would be visible, I'd edit, save my changes, and get on with things. I've since moved the test site's theme to the main site, made sure the main site was fully upgraded, and yet I'm not seeing an Edit Image button.

    Do I need to turn the feature on somehow? I never did so for the test site... Do I need to change some file permissions before the button automatically appears?

    Thanks in advance.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  3. thetanooki
    Member
    Posted 4 years ago #

    Hi esmi,

    Thanks for the tips. Unfortunately I just finished trying all three of those suggestions, including switching to the default theme AND simultaneously sticking the plugins in a plugins.hold folder, and still couldn't access the Edit Image button.

    Are there any other options I can try? Or has anyone experienced similar issues and managed to figure out a solution?

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    You could see if it's a memory issue.

  5. thetanooki
    Member
    Posted 4 years ago #

    I've increase the allowed memory before, since WordPress would consistently timeout when attempting to export (roughly 8k posts and 11k comments). It was set at 128M. I decided to try reducing it to a more normal 32M, as well as upping it to 256M. No luck.

    Is it designed to disable under any circumstances?

  6. thetanooki
    Member
    Posted 4 years ago #

    OK, I'm pretty sure this isn't WordPress or database related. Both sites (the main and the test) recently migrated from one server to another. I finally got the test site (where I know the editor was working before) installed on the new server, and the editor doesn't show up their either.

    Both WordPress installs are definitely updated to 2.9.2, so it must be a server thing that WordPress is checking before deciding not to provide the editor button. I'm triple checking to make sure all the file/folder permissions are the same to make sure that isn't an issue.

    If anyone knows what conditions need to be met for the editor to be visible, let me know. Otherwise, if anyone can help me figure out which core WP file the editor is in, maybe it will give me some clues as to where I need to look.

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    Is it designed to disable under any circumstances?

    No. It should work with a memory allocation of around 64M. What version of PHP is running?

  8. thetanooki
    Member
    Posted 4 years ago #

    5.2.6 on the old server (that worked), 5.2.9 on the new one.

    I started looking at media.php in the core files and noticed mention of "gd_edit_image_support" - I was told in the WordPress IRC channel that the GD library may be missing, and then told by my host that I'd need to "recompile apache with php to enable GD library" which I have no idea how to do :P

    I also noticed that the old server was using Apache 2.2.10, while the new server is running 2.0.63. I'm not sure if this matters as much though...

  9. esmi
    Forum Moderator
    Posted 4 years ago #

    I was told in the WordPress IRC channel that the GD library may be missing

    That was going be my next question! Honest! Unfortunately, I wouldn't really know where to start on recompiling apache. Not my area of expertise, I'm afraid. In fact, you're probably better off looking for help on a dedicated server admin/Apache forum with that. Ditto with the different Apache versions (although I wouldn't have thought that it would make a great deal of difference in terms of running PHP with GD library as long as it's Apache 2.x).

  10. thetanooki
    Member
    Posted 4 years ago #

    Thanks for your help esmi! I've managed to figure this out and resolve the issue, so I'll just explain what I did here in case anyone comes across this thread looking for a solution.

    In my case, turns out that the GD library was in fact missing. I had to log into WHM (I'm on a WHM/cPanel server), and towards the bottom of the left sidebar, I had to find Software > EasyApache (Apache Update). I loaded the previously saved config and kept most of the same options, but under the Exhaustive Options List in the PHP section I had to check to enable GD. From there, I recompiled Apache and the Image Editor was working fine from then on.

  11. wardas
    Member
    Posted 3 years ago #

    Bingo - the GD solution above solved my problem

Topic Closed

This topic has been closed to new replies.

About this Topic