WordPress.org

Ready to get started?Download WordPress

Forums

SimpleMap Store Locator
[resolved] Does not work with wordpress 3.5 (10 posts)

  1. T Klein
    Member
    Posted 1 year ago #

    Any of the developers out there that can respond to this? The search function does not work with 3.5, it just hangs on "loading".

    http://wordpress.org/extend/plugins/simplemap/

  2. Carl Rozema
    Member
    Posted 1 year ago #

    Same problem here. The search fields are shown, but the map keeps loading.

  3. jimesten
    Member
    Posted 1 year ago #

    Ditto ... when can we expect an update to this ... we use almost 150 plugins across out 1500+ sites .. only 2 have had issues with WP 3.5 and the other one was updated overnight last night.

    thanks,

    Jim

  4. wp_joost
    Member
    Posted 1 year ago #

    The solution : Open the file plugins/simplemap/classes/xml-search.php

    at line 115, add a second parameter to the wpdb->prepare function.

    change :
    wpdb->prepare( " ...QUERY_HERE... " );

    to :
    wpdb->prepare( " ...QUERY_HERE... ", $id);

    Source : http://make.wordpress.org/core/2012/12/12/php-warning-missing-argument-2-for-wpdb-prepare/

  5. jimesten
    Member
    Posted 1 year ago #

    Excellent. Thanks for quick reply!!

    Jim

  6. T Klein
    Member
    Posted 1 year ago #

    awesome, works for me! I knew what the problem was but I couldn't find the right spot to put it. Thanks a ton joost.

    How did you find the right file?

  7. wp_joost
    Member
    Posted 1 year ago #

    Hello again,

    You also need to change the remaining 'wpdb->prepare' in other files (xml-search.php, locations.php, import-export.php)

    Click here to download the 3 corrected php files and place them in the plugins/simplemap/classes folder.

    edit : @T Klein, I found the right file from the error message i got in Firebug, it pointed to line 115 in xml-search.php

    Good Luck!

  8. jimesten
    Member
    Posted 1 year ago #

    Even better!! I had already started down that path.. thanks for shortening it!

    peace,

    Jim

  9. ashbryant
    Member
    Posted 1 year ago #

    Thanks, seems to have fixed it.

  10. jbekefy
    Member
    Posted 1 year ago #

    Hi does the .rar file have all the necessary file updates, or is there more to do? I deleted the plug-in, replaced the original files with the three found in the .rar and uploaded it again. Unforutnately I'm still getting the infinite loading icon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.