WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Page Publish
Does not publish to FB (13 posts)

  1. Peggy
    Member
    Posted 2 years ago #

    I am not able to get any posts or pages to publish to my FB profile at all.

    I have it set to post to my profile, and have selected categories to publish from. I check the little publish to facebook box before I save the post or page. But there's nothing at all on my profile, nothing.

    What could I be doing wrong?

  2. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    Hi pgurney59,

    Could you post me a link to your blog and / or the result of http://your-blog-domain/wp-content/plugins/facebook-page-publish/diagnosis.php ?

  3. Peggy
    Member
    Posted 2 years ago #

    This is the result of the link above with my domain -
    http://peggygurney.com/wp-content/plugins/facebook-page-publish/diagnosis.php

    Everything looks fine

    Array
    (
    [headers] => Array
    (
    [cache-control] => no-store
    [content-type] => text/javascript; charset=UTF-8
    [expires] => Sat, 01 Jan 2000 00:00:00 GMT
    [pragma] => no-cache
    [www-authenticate] => OAuth "Facebook Platform" "invalid_client" "Error validating application."
    [x-fb-rev] => 423917
    [x-fb-server] => 10.36.11.118
    [connection] => close
    [content-length] => 77
    )

    [body] => {"error":{"type":"OAuthException","message":"Error validating application."}}
    [response] => Array
    (
    [code] => 400
    [message] => Bad Request
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    My url is http://peggygurney.com

    I just made another post and ticked the box "Publish to Facebook". It did not.

  4. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    Hi pgurney59,

    Thank you for your reply. I had a look at your page and inspected it with the FB debug tool, but it seems pretty normal (everything should be working fine). Since I cannot reproduce the problem on my own blog for testing purposes, I cannot fix it right now, but I would like to get rid of this bug soon.
    Do you use a standard wordpress installation?
    If you want to, you could also try out this alternative plugin and tell me whether it works for you or not (then I could have a look at the difference in its implementation): http://wordpress.org/extend/plugins/add-link-to-facebook/

  5. grisu59
    Member
    Posted 2 years ago #

    To me happen the same
    I connected blog http://www.pdudine.it
    to facebook page
    https://www.facebook.com/pages/Partito-Democratico-Udine/146337085412273

    But posts are not updated to FB!

  6. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    The problem might caused by your WP theme. What theme do you use?

  7. Peggy
    Member
    Posted 2 years ago #

    hmmm after your last reply to me, I was able to publish 3 posts to Facebook. Then the next 2 didn't publish, lol.

    I bet it's just facebook being silly again.

  8. coscooper
    Member
    Posted 2 years ago #

    No posting working here either. Application and secret settings all good. WordPress 3.2.1 and theme by Elegant WordPress Themes.

    Everything looks good on posts, nothing happens. Ideas?

    Site: http://www.nelsonparkhoa.org

    ------ Test debug ----
    Everything looks fine

    Array
    (
    [headers] => Array
    (
    [cache-control] => no-store
    [content-type] => text/javascript; charset=UTF-8
    [expires] => Sat, 01 Jan 2000 00:00:00 GMT
    [pragma] => no-cache
    [www-authenticate] => OAuth "Facebook Platform" "invalid_client" "Error validating application."
    [x-fb-rev] => 431605
    [x-fb-server] => 10.62.65.44
    [connection] => close
    [content-length] => 77
    )

    [body] => {"error":{"type":"OAuthException","message":"Error validating application."}}
    [response] => Array
    (
    [code] => 400
    [message] => Bad Request
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )
    Check if the SSL module is loaded

    Facebook requires secure https transmissions. Therefore your webserver has to support SSL. Not all hoster, especially freehoster, offer this service.

    Everything looks fine

  9. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    Hi coscooper,

    Thank you for posting the debug info! Is it still not working? I will have a look at the theme (I think it has to do something with the theme), but it will take some time (not before next week) unfortunately.

  10. awhig
    Member
    Posted 2 years ago #

    I also consistently get errors from the plugin, yet the diagnostics says everything is fine (though I can see the error in the diagnostic response) BUT our posts have always, and continue to post to our FB page.

    Here is what I see:

    Check if your server can connect to Facebook

    Sends a https request to Facebook to detect possible connection errors. Expects a code 400 / Bad request response.
    Everything looks fine

    Array
    (
    [headers] => Array
    (
    [cache-control] => no-store
    [content-type] => text/javascript; charset=UTF-8
    [expires] => Sat, 01 Jan 2000 00:00:00 GMT
    [pragma] => no-cache
    [www-authenticate] => OAuth "Facebook Platform" "invalid_client" "Error validating application."
    [x-fb-rev] => 450480
    [x-fb-server] => 10.54.6.37
    [connection] => close
    [content-length] => 77
    )

    [body] => {"error":{"message":"Error validating application.","type":"OAuthException"}}
    [response] => Array
    (
    [code] => 400
    [message] => Bad Request
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    Check if the SSL module is loaded

    Facebook requires secure https transmissions. Therefore your webserver has to support SSL. Not all hoster, especially freehoster, offer this service.
    Everything looks fine

  11. movieboozer
    Member
    Posted 2 years ago #

    I'm experiencing the same problem for http://www.movieboozer.com/

    Is there a fix coming?

  12. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    @all: I think the problems you are experiencing are the same as described here: http://wordpress.org/support/topic/plugin-facebook-page-publish-publish-fail#post-2374726

    I will post all status updates concerning this problem in the other thread.

  13. quixfix
    Member
    Posted 2 years ago #

    I am too am having problems. However, strangely it is only affecting 1 Page out of the several I have created. I am able to post tp FB with no problems on all pages except 1.

    Last night thru trial and error was able to get it to post correctly to FB in the right page but it only worked 2 times. Since then I am unable to get it to post.

    Any suggestions?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic