WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Landing Pages
[resolved] do not want prefix (10 posts)

  1. markusalfred
    Member
    Posted 11 months ago #

    Hello

    How do I get rid of default landing page permalink prefix? I want to use short links and if I leave it empty, it will put "landing-page" there.

    http://wordpress.org/plugins/landing-pages/

  2. David Wells
    Member
    Plugin Author

    Posted 11 months ago #

  3. markusalfred
    Member
    Posted 11 months ago #

    Hello, thank you for the answer. I noticed that there is a note on your plugins: this currently only works with normal landing page URLs and not for the A/B split testing URLs (/group/ urls).

    I do not understand, what is the use of it then if it is not going to work with A/B test? I understand that A/B test is the whole point of your landing page plugin :).

    If I still have prefix /go/ or whatever in my address, it is longer and not attractive.

    And what is the difference between free plugin you suggested and your own plugin? Can I remove prefix with the free plugin and still use A/B test?

    Thank you

  4. David Wells
    Member
    Plugin Author

    Posted 11 months ago #

    /group/ urls no longer exist with the plugin. Those were a v1 version of a/b testing.

    WordPress custom post types are not built for custom URL structures and the fix to remove them is not ideal.

    When you remove the beginning go /slug/ it will mess with the a/b testing functionality with both plugins.

    You are welcome to use the custom slugs plugin (and lose a/b testing) or change the /go/ to /whatever-you-want/ and keep a/b testing (recommended)

    Thats all we can do from a programatic standpoint. There might be some custom stuff you can do to your .htaccess file but it's not something we can support on a one off basis.

  5. markusalfred
    Member
    Posted 11 months ago #

    Hello

    I installed new version of your plugin.

    I changed /go/ to /info/ and none of the landing pages or versions A, B, C are available.
    http://www.projektid.ee/info/eas-starditoetus/

    I changed back to /go/ and still no luck.

    What is wrong?

  6. David Wells
    Member
    Plugin Author

    Posted 10 months ago #

    What does your htaccess file look like?

  7. markusalfred
    Member
    Posted 10 months ago #

    Hello, my htaccess lookes like this and I changed GO to info and then my page did not appear at all. I changed back and at least it shows my wp error page.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteRule ^go/([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteRule ^langing-page=([^/]*)? /wp-content/plugins/landing-pages/modules/module.redirect-ab-testing.php?permalink_name=$1 [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  8. David Wells
    Member
    Plugin Author

    Posted 10 months ago #

    Hmmm strange.

    Try this:
    1. Delete the plugin completely

    2. Restore your htaccess file to the wordpress default:
    (make a backup copy just in case you need to revert)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    3. Reinstall the latest copy of landing pages from WordPress repository.

    4. Then flush your permalinks by visiting the permalinks page in settings: http://docs.inboundnow.com/landing-pages/users/faq/fixing-landing-page-404-error

    That should bring landing pages back. If not there could be another plugin conflict.

  9. markusalfred
    Member
    Posted 10 months ago #

    I created landing page http://www.projektid.ee/info/kasvutoetus/ and there are several problems:

    1. It shows only on version. I tested it and it really showed only one and statistics also shows that.

    2. It does not track conversions. First of all I do not even see where can I set what is the goal page. I have adds on FB and I have FB pixel conversion on thankyou page (www.projektid.ee/thankyou) and I of course tested and I have not seen any conversion for days.

    3. I first created version A, then B. Then I liked B more and deleted A. Then wierd things started to happen. A came back... it just appeared. And it is still there. I tried several times.

    4. I use Getresponse forms, but I can not align it to center (at least on that template).

    5. I still have global settings prefix GO, but my addresses actually have /info/. This is what I wanted, but why there is setting that does not mean anything?

  10. David Wells
    Member
    Plugin Author

    Posted 10 months ago #

    Can you please delete whatever landing page version you are running and reinstall.

    1. The htaccess rewrites don't appear to be working on your server for whatever reason.

    2. your form does not have the tracking class on it. wpl-track-me <form accept-charset="utf-8" action="http://app.getresponse.com/add_contact_webform.html" method="post" target="_top">

    3. Please update

    4. You will need to write your own custom CSS for whatever form tool you are using. We can't do this for the thousands of form tools people use

    5. The setting should be updating. Please delete the plugin entirely and reinstall

Reply

You must log in to post.

About this Plugin

About this Topic

Tags