WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[closed] DO NOT UNINSTALL NextGEN if you are having issues with 2.0 (75 posts)

  1. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @daveslc - yes, the instructions are accurate and are the easiest & risk free way of rolling back a version.

    If you are a confident working with files via FTP, you can temporarily rename the nextgen-gallery folder under /wp-contents/plugins/... to something like _nextgen-gallery and then re-upload the old copy of nextgen-gallery from the v1.9.13 folder. Once you re-activate and confirm all is working well, you can go back and delete the renamed copy from your server. I would only recommend doing it this way if you are 100% confident working with your server files via FTP.

    Hope that helps!
    -Becky

  2. tdiaz
    Member
    Posted 1 year ago #

    After reading "what still doesn't work" in the latest beta, stay the heck far away from it.

    This really appears to be a quick pushout to generate revenue with 'Pro' sales, and nothing more.

    Some questions that I can't find addressed anywhere else:

    What happens with custom templates and short codes?

    Since one of the blog entries says "short codes are not required" and one of the bug entries says they don't even work. If you have an installation that is built on these, I've got to presume that 2.0 is not for you.

  3. Gordana589
    Member
    Posted 1 year ago #

    2.0 AFTERMATH

    My galleries didn't like NextGen 2.0 either -- no fatal errors but all sorts of random issues that made the galleries unusable.

    I run a modified Genesis Minimum Theme and have Contact Form 7 plugin, among the others.

    OLD VERSION REINSTALL HICKUPS

    Reinstalling my previous version (1.9.13) -- by following the instructions -- went smoothly, BUT the galleries didn't look like they used to:
    - several images from various albums/galleries had to be renamed
    - the images in a couple of galleries had to be reordered
    - one album was shown as empty and had to be repopulated with its galleries -- the galleries were fine

    NEXT?

    I will wait for a rock-solid, much improved update of 2.0. Good luck to Becky and the rest of the Photocrati crew with fixing the problems!

  4. quirkylissy
    Member
    Posted 1 year ago #

    Tried rolling back, doesn't help. Waiting for a permanent fix.

  5. PamelaSandall
    Member
    Posted 1 year ago #

    Well, I didn't read all pages of comments as they seemed to be saying similar things. I can't insert any of my galleries or change or fix the existing ones.

    When I try to insert any gallery into a page/post, the window pops up with this error message:
    Fatal error: Call to undefined function get_current_screen() in /home3/psdesign/public_html/wp-content/themes/pitch/premium/functions/slide.php on line 9

    And yes, after seeing your recommendation to roll it back (something I didn't know how to do), I cancelled my morning plans and spent the first two hours learning this instead. I would have been fine with the learning experience, but it STILL doesn't work.

    Please advise. For now, I will remove all the shortcodes from all of my galleries and wait for updates?

  6. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @PamelaSandall - This error appears to be addressing your installed theme 'Pitch', if you were to temporarily switch to a WordPress default theme does that error go away?

    -Becky

  7. PamelaSandall
    Member
    Posted 1 year ago #

    Perhaps, but I haven't made any changes to my theme. And it worked in it's original version. I've not changed, edited or upgraded my theme since installing your plug-in. Besides, I don't want to use the generic theme. The only changes I'd made when this showed up was to upgrade NextGen.

    If you're reading this again, here's the full scenario: I spent an entire Sunday learning your plug-in and uploading over 100 images and organizing, categorizing, labeling, tagging. (Literally ALL day).

    The next morning there was an update suggested. Which I did. Suddenly I was having other issues. All the file names which I had deleted off each and every picture (so they didn't display on the top) were fully on display at the top of the each image. Since I use the image name with descriptive terms, they are NOT pretty, you know? So I spent the morning working on THAT inconvenience.

    Also, all the images shifted from full size & centered, to smaller and all justified to the left. Since the box is centered so it's definitely the plug-in and not my formatting. I was unable to find a work-around for that. You can view it here:

    http://www.pamelasandalldesign.com/bedrooms/

    I posted these issues in this forum when they happened. No solution was suggested other than to use a different layout. Which is sad, as the reason I selected your product and spent an entire Sunday working with your galleries was to achieve those big, bold images. However, since it looks SUPER unattractive (off center and ugly labels) and I'm in the business of needing the aesthetics to be great, I went in this morning to change the way the galleries would display. ONLY to discover that I have no ability to CHANGE the galleries, only to delete them. I even tried starting with new page. Didn't work.

    Soooo, I took MORE time out of my schedule to learn how to fix it only to find it didn't change a thing. If you have a suggestion, I would love to have not wasted two days of time on this, so please let me know.

    Thanks.

  8. siemslikelynn
    Member
    Posted 1 year ago #

    Plugin update pretty much shut down my entire site.

    Rolling back was easy, did not use the OP method (I hadn't read it at that point), all I did after grabbing one version prior in .zip format was:

    1) Rename the original plug-in directory under wp-content/plugins/nextgen-gallery to _nextgen-gallery

    2) Go back to WordPress, Add Plugin > Upload > Select the .zip file for your downloaded previous version.. install, and activate.

    Bam. Had it up and running in 2 minutes or less. It automatically hooked up with the gallery files. I didn't have to change any code, didn't have to copy any files, etc.

  9. joesernio
    Member
    Posted 1 year ago #

    Anyone having shortcode issues? None of the new shortcodes work when upgraded to the new version...

  10. tdiaz
    Member
    Posted 1 year ago #

    http://www.nextgen-gallery.com/nextgen-gallery-2-0-shortcodes/

    Reading this .. makes me wonder "what new shortcodes?" they say they don't use them anymore, and then there are other articles that tend to say different.

    This rollout has not been very smooth at all.

  11. joesernio
    Member
    Posted 1 year ago #

    Agree 100% What a mess

  12. SFrueh
    Member
    Posted 1 year ago #

    Because I can't install the hotfix for unknown reasons I might have to try the rollback.
    Someone tried the rollback after (failed?) installation of the hotfix?

    I'm really not happy with trying the rollback, but I'm running out of ideas.

    When will there be the official update?
    In a day? Three days? A week?

    I can hardly afford waiting much longer for a functionating gallery. I would be really happy If I could keep NextGEN because swithing to another gallery plugin would mean to re-upload 2.000 pictures...

  13. siemslikelynn
    Member
    Posted 1 year ago #

    @SFrueh I rolled back without a problem, I posted a few posts above you.

  14. joesernio
    Member
    Posted 1 year ago #

    Has anyone gotten the new version to work on their pages with the new shortcodes?

  15. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Hi all - just a note that we've pushed out 2.0.7 which solves quite a few issues. See here for a list of what's included:

    http://www.nextgen-gallery.com/nextgen-gallery-2-0-7/

    For now, I'm going to request moderators close this post so we can encourage user to post new issues in separate threads. Not trying to be crazy about that, but it's much easier for us (and for any other users having a similar issue) to find issues when they have their own independent threads. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.