WordPress.org

Ready to get started?Download WordPress

Forums

Do not moderate Authors comments - how? (10 posts)

  1. jsdesign
    Member
    Posted 6 years ago #

    I have a private blog for my family and I wish to set it that I do not want to moderate comments made by the registered members of the blog. The blog is password protected and private, so I'm not concerned about spam. Is there an easy way to do this or plugin available? The only way I have found is to set everyone as an administrator, but I forsee trouble if somebody starts to tinker with the blog settings. Please help!

  2. IainPurdie
    Member
    Posted 6 years ago #

    Go to Settings on the right hand side.

    Select Discussions on the large menu on the left that appears

    Third section down ("Before a comment appears") ensure that the top box isn't ticked ("An administrator must always approve the comment")

    May also be worthwhile clearing the other two boxes.

  3. jsdesign
    Member
    Posted 6 years ago #

    That does not work. After writing a comment, the user still receives the message 'your comment is awaiting moderation'. Is this a bug?

  4. IainPurdie
    Member
    Posted 6 years ago #

    Silly question, but are the people who are trying to post actually registered as users yet? They can be registered as subscribers or a similar role which should allow them to skip the moderation bit.

    Under Settings / General about halfway down there is a tickbox for "Users must be registered and logged in to comment". Is this ticked? And is the person trying to post a comment logged in?

    I've never used the registration system, so I don't know the errors that pop up dependant on what options you have selected, I'm afraid. Just looking at the options available :)

  5. Roy
    Member
    Posted 6 years ago #

    Why just don't make the settings to anyone can comment and no moderation queue?

  6. IainPurdie
    Member
    Posted 6 years ago #

    As far as I can gather, that is what jsdesign has done, yet it isn't working.

  7. jsdesign
    Member
    Posted 6 years ago #

    I'm using the Private WP plugin, so users have to be registered before they can actually see the site. All the registered users are set as Author for their role. As far as I can see, I've set everything up correctly. even tried setting them as an editor, their comments still require moderation, but then they can go and approve their own comment. But I don't want to do that, because really, they shouldn't have to do it. I just want them to be able to comment and that's it.

  8. IainPurdie
    Member
    Posted 6 years ago #

    Hmm... I'm not familiar with the plug-in (heard of it, but not used it) so I'm not sure of the effect it would have. As an experiment, try disabling the plug-in. From what I gather it only protects the *site* from prying eyes, not the ability to comment.

    I'd suggest small steps - see if you/we can get it going without the plug-in first and *then* activate Private-WP.

  9. jsdesign
    Member
    Posted 6 years ago #

    Tried deactivating it, but same moderation message comes up when commenting, so its not that plugin.

  10. IainPurdie
    Member
    Posted 6 years ago #

    I must confess, I am now at somewhat of a loss. All I can suggest is to go back to basics. Have the blog set up wide open and gradually secure it bit by bit until you hit the problem (or - hopefully - bypass it).

Topic Closed

This topic has been closed to new replies.

About this Topic