WordPress.org

Ready to get started?Download WordPress

Forums

Broken Link Checker
Does not detect links in posts (3 posts)

  1. ZkilfinG
    Member
    Posted 1 year ago #

    I'm a new user of BLC and love the concept. However BLC does not detect links inside blogposts. Only within pages. I have BLC 1.7.1 and WP 3.5.1. All settings looks good and no error that I can see in the debug info.

    The blog is available here: http://idaotterholm.se/category/blogg/

    Debug:
    PHP version 5.3.10
    MySQL version 5.5.21
    CURL version 7.24.0
    Snoopy Installed
    Safe mode Off
    open_basedir Off
    Default PHP execution time limit 30 sekunder
    Resynch. flag 0
    Synch. records 113
    Unparsed items 0
    Link records 0 (0)
    Installation log Plugin activated at 2012-04-10 18:33:18.
    Installation/update begins.
    Upgrading the database...
    [OK] CREATE TABLE IF NOT EXISTS wp_idaotterholm__1_blc_filters ( id int(10) unsigned NOT NULL AUTO_INCREMENT, name varchar(100) NOT NULL, params text NOT NULL, PRIMARY KEY (id) ) DEFAULT CHARACTER SET utf8
    [OK] CREATE TABLE IF NOT EXISTS wp_idaotterholm__1_blc_instances ( instance_id int(10) unsigned NOT NULL AUTO_INCREMENT, link_id int(10) unsigned NOT NULL, container_id int(10) unsigned NOT NULL, container_type varchar(40) NOT NULL DEFAULT 'post', link_text varchar(250) NOT NULL DEFAULT '', parser_type varchar(40) NOT NULL DEFAULT 'link', container_field varchar(250) NOT NULL DEFAULT '', link_context varchar(250) NOT NULL DEFAULT '', raw_url text NOT NULL, PRIMARY KEY (instance_id), KEY link_id (link_id), KEY source_id (container_type, container_id), KEY parser_type (parser_type) ) DEFAULT CHARACTER SET utf8
    [OK] CREATE TABLE IF NOT EXISTS wp_idaotterholm__1_blc_links ( link_id int(20) unsigned NOT NULL AUTO_INCREMENT, url text CHARACTER SET latin1 COLLATE latin1_general_cs NOT NULL, first_failure datetime NOT NULL DEFAULT '0000-00-00 00:00:00', last_check datetime NOT NULL DEFAULT '0000-00-00 00:00:00', last_success datetime NOT NULL DEFAULT '0000-00-00 00:00:00', last_check_attempt datetime NOT NULL DEFAULT '0000-00-00 00:00:00', check_count int(4) unsigned NOT NULL DEFAULT '0', final_url text CHARACTER SET latin1 COLLATE latin1_general_cs NOT NULL, redirect_count smallint(5) unsigned NOT NULL DEFAULT '0', log text NOT NULL, http_code smallint(6) NOT NULL DEFAULT '0', status_code varchar(100) DEFAULT '', status_text varchar(250) DEFAULT '', request_duration float NOT NULL DEFAULT '0', timeout tinyint(1) unsigned NOT NULL DEFAULT '0', broken tinyint(1) NOT NULL DEFAULT '0', may_recheck tinyint(1) NOT NULL DEFAULT '1', being_checked tinyint(1) NOT NULL DEFAULT '0', result_hash varchar(200) NOT NULL DEFAULT '', false_positive tinyint(1) NOT NULL DEFAULT '0', PRIMARY KEY (link_id), KEY url (url(150)), KEY final_url (final_url(150)), KEY http_code (http_code), KEY broken (broken) ) DEFAULT CHARACTER SET utf8
    [OK] CREATE TABLE IF NOT EXISTS wp_idaotterholm__1_blc_synch ( container_id int(20) unsigned NOT NULL, container_type varchar(40) NOT NULL, synched tinyint(3) unsigned NOT NULL, last_synch datetime NOT NULL DEFAULT '0000-00-00 00:00:00', PRIMARY KEY (container_type,container_id), KEY synched (synched) ) DEFAULT CHARACTER SET utf8
    Database schema updated.
    Database successfully upgraded.
    Cleaning up the database...
    ... Deleting invalid container records
    ... 0 synch records deleted
    ... Deleting invalid link instances
    ... 0 instances deleted
    ... 0 more instances deleted
    ... Deleting orphaned links
    ... 0 links deleted
    Notifying modules...
    ... Updating module cache
    ... Notifying module "http"
    ... Notifying module "link"
    ...... Parser "link" is marking relevant items as unsynched
    ...... Executing query: UPDATE wp_idaotterholm__1_blc_synch SET synched = 0 WHERE (container_type = 'page' AND last_synch >= '1970-01-01 00:00:00') OR (container_type = 'post' AND last_synch >= '1970-01-01 00:00:00') OR (container_type = 'comment' AND last_synch >= '1970-01-01 00:00:00')
    ...... 0 rows affected
    ... Notifying module "image"
    ...... Parser "image" is marking relevant items as unsynched
    ...... Executing query: UPDATE wp_idaotterholm__1_blc_synch SET synched = 0 WHERE (container_type = 'page' AND last_synch >= '1970-01-01 00:00:00') OR (container_type = 'post' AND last_synch >= '1970-01-01 00:00:00') OR (container_type = 'comment' AND last_synch >= '1970-01-01 00:00:00')
    ...... 0 rows affected
    ... Notifying module "metadata"
    ...... Parser "metadata" is marking relevant items as unsynched
    ...... Executing query: UPDATE wp_idaotterholm__1_blc_synch SET synched = 0 WHERE (container_type = 'custom_field' AND last_synch >= '1970-01-01 00:00:00')
    ...... 0 rows affected
    ... Notifying module "url_field"
    ...... Parser "url_field" is marking relevant items as unsynched
    ...... Executing query: UPDATE wp_idaotterholm__1_blc_synch SET synched = 0 WHERE (container_type = 'comment' AND last_synch >= '1970-01-01 00:00:00') OR (container_type = 'blogroll' AND last_synch >= '1970-01-01 00:00:00')
    ...... 0 rows affected
    ... Notifying module "blogroll"
    ... Notifying module "comment"
    ...... Deleting synch. records for removed comments
    ...... 0 rows affected
    ...... Creating synch. records for new comments
    ...... 0 rows affected
    ... Notifying module "post"
    ...... Deleting synch records for removed posts
    ...... 0 rows deleted
    ...... Marking changed posts as unsynched
    ...... 0 rows updated
    ...... Creating synch records for new posts
    ...... 9 rows inserted
    ... Notifying module "page"
    ...... Skipping "page" resyncyh since all post types were already synched.
    ... Notifying module "dummy"
    Updating server load limit settings...
    Optimizing the database...
    Completing installation...
    Configuration saved.
    Installation/update completed at 2012-04-10 18:33:19 with 29 queries executed.

    http://wordpress.org/extend/plugins/broken-link-checker/

  2. ZkilfinG
    Member
    Posted 1 year ago #

    I think it might be related to what this tutorial is trying to solve: http://www.tastyplacement.com/wordpress-tutorial-display-all-posts-on-a-page

  3. ZkilfinG
    Member
    Posted 1 year ago #

    Not sure if I did something wrong, but that tutorial didn't help me. I've also tried to inactivate/delete and reinstall BLC but it didn't help either.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.