WordPress.org

Ready to get started?Download WordPress

Forums

Do Not Allow Comments not working (7 posts)

  1. SBiglow
    Member
    Posted 1 year ago #

    I have been trying to cull the numerous (read thousands per post) spam comments on my site. I've gone in and done bulk edit on them and done "do not allow" comments. I think it works except I logged into my dashboard this morning to find one of the posts I'd culled down to 0 comments now had 36. I'd really like to make it so people cannot post new comments on existing posts. I've got it so they can't comment on posts going forward.

    Any help would be greatly appreciated. If it helps, I'm running version 3.5 and my Theme is Bouquet by Anonymous (version 1.0-wpcom). I do see that my theme has an update to version 1.1 but I haven't updated yet.

  2. linux4me2
    Member
    Posted 1 year ago #

    I would think that if you did a bulk edit and turned commenting off, that would take care of it.

    If you have access to your database via phpMyAdmin, try running the following SQL query to find any posts that aren't closed to comments:
    SELECT * FROM wp_posts WHERE comment_status <> 'closed'
    You'll have to change "wp_posts" to the name you're using for the posts table if it's different.

    If there are any posts that are still open for comments, you can quickly change that by running this query:
    UPDATE wp_posts SET comment_status = 'closed'

    Note: You should back up the posts table before running queries directly on it like this unless you are very confident of what you are doing!

    If there are no posts that aren't closed to commenting, and you're still getting them, something isn't right. It sounds like a hack of some kind if someone is able to post when commenting is closed on the commented-upon posts.

    Do you have Akismet activated by the way?

  3. SBiglow
    Member
    Posted 1 year ago #

    As far as I know I don't have Akismet activated. I'm still getting comments coming through but I've sort of got a work around. I've set it so that all comments need moderation so at least they get caught in the mod queue now instead of going up. Not a permanent fix by any means but it works sort of.

    I'm not running it through phpMyAdmin unfortunately or I'd run the search queries as suggested.

  4. linux4me2
    Member
    Posted 1 year ago #

    Akismet works very well, so it would be worth looking into.

    Do you have SSH access to your server or some other database access through your host? You can run SQL queries with those, too, though it may not be as easy as with the phpMyAdmin GUI.

  5. SBiglow
    Member
    Posted 1 year ago #

    Just activated it. So we will see if it helps. Thanks for the suggestion.

  6. Roar
    Member
    Posted 1 year ago #

    Oh yes, you definitely need Akismet.

    Also, under discussions, be sure to close comments on articles over ** days old, that helps.

    And make sure to also turn off trackbacks.

    :)

  7. SBiglow
    Member
    Posted 1 year ago #

    So I don't think I have trackbacks on which is good and I just closed comments on articles more than 14 days old which covers everything except the post I made on the 4th but that's closed to comments anyway. Here's hoping all of these combined measures make the evil evil spambots leave me alone. Deleting 37,000 spam comments is tiring (and yes part of it is my fault for sorta going AWOL...what with getting a full-time job and moving and stuff).

    Thank you again to both of you.

Topic Closed

This topic has been closed to new replies.

About this Topic