WordPress.org

Ready to get started?Download WordPress

Forums

DMSGuestbook not showing on page (12 posts)

  1. motasim
    Member
    Posted 3 years ago #

    Hi,

    I've installed and activated DMSGuestbook plugin. Then I selected the desired page from the options BASIC in DMSGuestbook settings. But the guestbook doesn't show up on that page.
    Also, when I again go to setting > Basic, the selected page shows unselected.
    How to solve this and display the guestbook on my page of choice.

    Thanks.

  2. motasim
    Member
    Posted 3 years ago #

    Got it!

  3. Ovidiu
    Member
    Posted 3 years ago #

    how did you solve it?

    I follow the instructions,clear all, select language, then click set and then save. still nothing happens and when I navigate back to this options page it looks unset, just as before :-(

  4. bhoover
    Member
    Posted 3 years ago #

    I'm having the same problem. The language is not saving. Also, if I try to activate and publish the guestbook, I get a 404.

  5. DanielSchurter
    Member
    Posted 3 years ago #

    If you have a problem to save your changes in the setting section you can do that manually on 'DMSGuestbook -> Database settings -> DMSguestbook options backup'

    Greetings,
    Dani

  6. Ovidiu
    Member
    Posted 3 years ago #

    thx. found the help, really helpful, once I noticed it and used it :-)

    a little documentaion would be helpful but I managed to get by....

    i.e. I had to guess that '<require_antispam>2</require_antispam> /* require antispam */'

    takes 0=don't use, 1=antispam image and 3=antispam math figures

    btw. any quick solution to be able to display

    a) a random number of comments via the widget and not the latest ones?

    b) a certain comment? i.e. by specifying the comment ID or IDs if multiple are selected?

  7. DanielSchurter
    Member
    Posted 3 years ago #

    Hi Ovidiu

    On 'dmsguestbook/widget.php' there is the sql statement on line 73.

    Greetings,
    Dani

  8. Ovidiu
    Member
    Posted 3 years ago #

    thanks Dani, you're really fast.

    line 73 reads: $query_posts = $wpdb->get_results("SELECT ID, post_title FROM $table_posts WHERE ID = $multi_page_id[$m] ORDER BY id ASC");

    as far as I can udnerstand that as a non-coder I would have to randomize the variable m?
    I'll give it a try but seriously if its not a quick fix, don`t bother. you already made a great product so this support is by no means reauired, it would jsut help me if I could show certain or random coments.

    cheers
    Ovidiu

    oh and btw. none of my settigns is being saved. I even deleted the plugin's options and its tables, deactivated and reactivated it but still none of the options I set from the backend is being saved.
    I am currently editing everything via phpmyadmin...

  9. DanielSchurter
    Member
    Posted 3 years ago #

    Hi Ovidiu

    I told you a mistake, it's not the line 73.

    There is a quick and dirty solution to randomize the widget output on every refresh. This RAND() statement is not very efficient but if you have no more than 10'000 rows it does not matter. :-)

    Go to the line 310 on your widget.php file and replace your exist code with this one:
    $query = $wpdb->get_results("SELECT id, name, message, date, gravatar FROM $table_name WHERE flag != '1' && guestbook = '" . sprintf("%d", $guestbook_id_part1[0]) . "' && spam = '0' ORDER BY RAND() " . sprint ("%s", $part2[0]) . " LIMIT " . sprintf("%d", $entries) . "");

    Greetings,
    Dani

  10. web-bart
    Member
    Posted 2 years ago #

    I'm sorry, this post is opened a while ago. But I'd not open up a new one, becouse here are people who know the awnser are subscribed (I hope), and becouse 1 post with the same title is enough.

    The problem is that I can't publish the guestbook, and that the settings don't get changed.
    -----------
    This is what've tryed to fixx it but it didn't work:

    click on the plug-in 'DMSGuestbook' on the left side

    click on 'database settings'

    click on 'DMSGuestbook options backup'

    click on 'safe'
    -----------

    What did I wrong? And how can I fix this? If possable give a detailed description, becouse I dont understand all the 'wordpress terms' :p

    If you need this info: I use the database system 'plesk'

    Kind regards,

    web-bart

  11. DanielSchurter
    Member
    Posted 2 years ago #

    Hi web-bart

    Would you like to restore an exist configuration? Then go to 'DMSGuestbook -> Database settings -> DMSGuestbook options backup' and restore that.

    Otherwise you should using 'DMSGuestbook -> Guestbook settings'. If there is a problem that non of your data are saving, tryout another web browser (e.g. Firefox) or create me an wordpress admin account and send me the credentials to DMSGuestbook {at} DanielSchurter (dot) Net. I will check this as soon as possible.

    Greetings,
    Dani

  12. web-bart
    Member
    Posted 2 years ago #

    Hey,

    I've found it. Thanks for the fast awser. Normaly I'm used to wait weeks, or sometimes months to wait for an awnser. My problem was this, and this way I've fixed it:

    I was forget to click 'clear all'. After clicking that it worked.

    Kind regards,

    webbart

Topic Closed

This topic has been closed to new replies.

About this Topic