WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] div stacking / floating in header (3 posts)

  1. ellentolsma
    Member
    Posted 1 year ago #

    Hi - can someone lend me a hand with 'cleaning up' my header's layout? It's driving me mad after a full day of trying... This is the code for my header:

    <body <?php body_class(); ?>>
    
    	<header id="header">
    
    		<div class="container">
    
    			<div class="one-third column">
    
    				<a id="logo" title="<?php echo get_bloginfo('name'); ?>" href="<?php echo home_url( '/' ); ?>">
    
    					<?php $image=theme_resize(get_theme_option('logo_image'),get_theme_option('logo_width'),0,true,false); ?>
    
    					<img src="<?php echo $image[0]; ?>" width="<?php echo $image[1]; ?>" height="<?php echo $image[2]; ?>">
    
    </a>
    </div>	
    
    <div class="two-thirds column" style="float:right">
    
    <?php wp_nav_menu( array( 'sort_column' => 'menu_order', 'container' => false, 'theme_location'  =>'main_nav', 'menu_id' => 'nav')); ?>	
    
    </div>
    
    <div class="sixteen columns" style="float:right">	
    
    				<ul id="social_icons" class="clearfix">
    
    				<?php $social_icons=explode(',',get_theme_option("social_icons")); ?>
    
    				<?php foreach($social_icons as $icon): ?>
    
    					<li>
    						<a target="_blank" href="<?php echo get_theme_option("social_icons_".$icon); ?>" title="<?php echo $icon; ?>" align>
    
    							<img class="active" src="<?php echo THEME_IMG; ?>/social_icons/<?php echo $icon; ?>.png" />
    							<img class="grayscale" src="<?php echo THEME_IMG; ?>/social_icons_gray/<?php echo $icon; ?>.png" />
    
    						</a>
    					</li>
    
    				<?php endforeach; ?>
    
    				</ul>
    				</div>
    
    </div>
    
    	</header>
    </body>

    And here's a link to what it looks like:
    http://screenpmd.com/wp-content/uploads/2013/03/Wordpress_support_header.jpg

    The logo is good where it is, so is the main navigation. I'd like to align the social bar (now on top of the logo)to the right, just under the main navigation menu. Any help is much appreciated!

  2. bcworkz
    Member
    Posted 1 year ago #

    This appears to be primarily a CSS issue. For anyone to be able to help you, they would almost surely need a link to the actual page that you're having trouble with, in order to identify the actual CSS involved.

  3. ellentolsma
    Member
    Posted 1 year ago #

    Thanks, you helped me already! Had a close look at the style sheet & found the 'problem'. Now adjusted and perfectly aligned to the right.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags