WordPress.org

Ready to get started?Download WordPress

Forums

Displaying Other Languages (3 posts)

  1. apc33
    Member
    Posted 2 years ago #

    I'm starting a blog where different authors will be writing in different languages (Japanese, French, Portuguese, Chinese, etc.). All I want is for WordPress to display those languages when articles are published.

    I do *NOT* want any translation tools! I want to be able to simply type, publish, and display. I also want people to be able to comment in each respective language.

    At the moment, any time I type Japanese or French, etc., into a post or page edit form, I can see the characters perfectly well, but as soon as I save the draft or publish it, all I get are question marks (????) or strange characters.

    I tried commenting out the following in wp-config.php: define('DB_CHARSET', 'utf8');
    which worked, but it totally screwed up my theme's functionality (Catalyst 1.4.1).

    I just want to be able to type and display in any language, just like I can do on any free blog at WordPress.com.

    Any help would be greatly appreciated.

  2. apc33
    Member
    Posted 2 years ago #

    Does anybody know how to do this? I see instructions on this site for how to change the admin display to another language, but how to get posts to display in other languages is not clear.

    In addition to what I wrote above, I also created a languages folder in wp-content and uploaded the ja.mo file, to see if WP would automatically draw up it to display Japanese characters, but it didn't help.

    I also changed collation of my SQL database tables in phpmyadmin to utf8, but that doesn't help either.

    Nothing I do seems to help! What am I missing?

    Please help me.

  3. apc33
    Member
    Posted 2 years ago #

    I finally found the source of the issue: fantastico. It was installing wordpress using the default collation at the server level: latin_swedish_ci. I deleted the site and database (since it was a new install anyway) and installed it manually, setting the database collation to utf8_general_ci *before* installing wordpress. After that, Japanese characters showed up just fine.

    I also found out that there is a script you can run to convert a database to UTF8: http://www.inmotionhosting.com/support/website/databases/how-to-convert-a-database-to-utf-8

Topic Closed

This topic has been closed to new replies.

About this Topic