WordPress.org

Ready to get started?Download WordPress

Forums

Seriously Simple Podcasting
[resolved] Displaying content without player in single.podcast.php (10 posts)

  1. Nyota
    Member
    Posted 1 year ago #

    I would like to display only the content of a podcast post without the player in single-podcast.php. I called the player separately and now I have two players showing up. The one I called and the one that is automatically displayed with the_content(); Is there a way of displaying only the content without the player? Using the_content(); still displays the player even with a custom wp_query.

    Thanks in advance.

    http://wordpress.org/plugins/seriously-simple-podcasting/

  2. jolaedana
    Member
    Posted 1 year ago #

    Nyota, this is pretty much my issue as well. I want to move the player from the top of $the_content to farther down the page.

    How did you call the player to single-podcast.php if you don't mind my asking? Have you seen issues with incorrect time stamps and information on the player once you have multiple podcasts uploaded?

    This was my problem with calling it separately within the template.

  3. jolaedana
    Member
    Posted 1 year ago #

    Nyota,

    I have solved my problem by modifying lines 490 - 501 in classes/class-seriously-simple-podcasting.php very slightly so that the content and meta data are switched in order.

    I know you weren't looking to move the player, but this code is what controls the display of the player in single podcast posts, so your answer probably lies there!

    Hope this helps.

  4. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    I have added an option in the latest version of the plugin (v1.6) that gives you the option to remove the audio player whenever you use the_content(). You simply need to check that option int he settings and the audio player will no longer show on your single podcast pages.

  5. tmarsh1
    Member
    Posted 1 year ago #

    Hey Hugh
    Am having trouble getting this into iTunes!

    The plugin is telling me my feed is: http://www.velonomad.com/?feed=podcast
    Here's a post. http://www.velonomad.com/podcast/podcast-666km-non-stop-alps-ride-interview-with-mike-cotty/
    Have tried that feed in Feedblitz too.
    What am I doing wrong?

    Tim

  6. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like you also have Blubrry PowerPress activate on your site. Any other podcasting plugin will conflict with SSP, so please deactivate Blubrry PowerPress and any other podcasting plugin that you may have installed. That should fix your problem up for you.

    In the future, please add a new topic when posting a new question - it helps to keep things more structured.

  7. tmarsh1
    Member
    Posted 1 year ago #

    Am getting an error in iTunes when submitting, have syndicated via Feedblitz.

    <img src="http://i.imgur.com/9845H0l.jpg" title="Hosted by imgur.com" />

  8. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 1 year ago #

    Yes - that's because you have Blubrry PowerPress active on your site. Deactivating Blubrry PowerPress will fix your problem.

  9. tmarsh1
    Member
    Posted 1 year ago #

    Hugh, can I suggest making the instructions in the plugin a bit clearer?
    For example.

    1. No other podcasting plugins enabled (Blubrry broke my feed).
    2. For the categories, can you grab iTunes' latest and let user choose? I made a tiny error in my input and it broke the feed (made it invalid)
    Got it working now though!!!
    It's great!

  10. Nyota
    Member
    Posted 1 year ago #

    @Hugh Lashbrooke Thank you for the update! Worked like a charm :)
    @jolaedana Thank you anyway :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.