WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Display WordPress Posts (Jetpack) not updating... (26 posts)

  1. Walter
    Member
    Posted 6 months ago #

    I'm thoroughly confused about where to post this... was asked not to add it to an existing thread by a mod... did that, then was asked to repost it in this subforum. Please understand it was/is not my intent to post more than once.

    The site using the widget is http://abbotvillagepress.com, trying to display posts from http://wboomsma.com. When first installed it listed the most recent posts... but that hasn't changed since and I've added posts to wboomsma.com. I am using very few of the other Jetpack Widgets (Facebook Like, Blog subscriptions) as this is a relatively new site that I'm just starting.

    I've also removed and then added the widget back. It is still showing the old posts even though I've added several new posts to wboomsma.com.

    http://wordpress.org/plugins/jetpack/

  2. I'm thoroughly confused about where to post this

    No idea what's confusing... Posting in the dedicated sub forum for any plugin in theme is always the best place to do that. You were provided that link to post here twice and I'm glad you posted here now. ;)

    was asked not to add it to an existing thread by a mod

    Yes and that mod did right. Your problem deserves it's own topic and interrupting someone else's is considered rude.

    The site using the widget is http://abbotvillagepress.com, trying to display posts from http://wboomsma.com. When first installed it listed the most recent posts... but that hasn't changed since and I've added posts to wboomsma.com

    Which Jetpack widget are you trying to use? I mean when you go to the widgets page on http://abbotvillagepress.com what's the label on the widget? That may make it easier to troubleshoot your problem.

  3. Walter
    Member
    Posted 6 months ago #

    Your problem deserves it's own topic and interrupting someone else's is considered rude

    Understood... but as I explained in my post on that thread I was having what seemed to be exactly the same problem as the original poster of that thread. I had no intention of being rude. It appeared the original poster had stopped responding to the suggestions and questions--I was willing to.

    The widget is the one give in the subject line: "Display WordPress Posts (Jetpack)" It is the one designed to show recent posts from a different WordPress site. On http://abbotvillagepress.com it is in the side bar with the heading "Recent Posts: Brain Leaks and Musings."

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    I tested the widget on a test site of mine, and it seems to be working properly:
    http://i.wpne.ws/TAqx

    Do you use a caching service or plugin on your site? If so, could you try to deactivate it or clear your plugin cache, and let me know if it helps and if the widget gets refreshed?

    If that doesn't help, could you try to remove the widget, and then add it again? Do new posts get added?

    Thanks!

  5. Walter
    Member
    Posted 6 months ago #

    Thanks...

    I deactivated WP Super Cache--this had no effect--just kept seeing those same posts. I had already removed and added the widget with no effect.

    I tried removing the widget while WP Super Cache was deactivated and that resulted in the message "unable to load blog data at this time."

    I reactivated WP Super Cache and still see the message "unable to load blog data at this time."

    So these steps seem to have taken me from seeing an unchanging list of posts to seeing the error message.

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    Alright. We're making progress. I still can't reproduce the problem on my end, but that error message gives us a better idea of the problem on your site.

    Could you make a screenshot of your current widget settings, and post it here? You can use a service like http://snag.gy/ to share your screenshot with us.

  7. Walter
    Member
    Posted 6 months ago #

    I assumed you meant the widget itself... I had to reinstall it to do so... now it is back to showing the older posts and not the error message. But I also noticed something interesting this time... in the side bar, this widget appears within another widget! You should be able to see what I mean by visiting the site http://abbotvillagepress.com.

    http://snag.gy/ap8Kx.jpg

  8. Walter
    Member
    Posted 6 months ago #

    Just noticed I said that backwards... the next widget appears within the border of this widget... hope that was the correct way to post the screen shot.

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    Thanks for the extra details. I've asked one of our developers to have a closer look at this, and I'll get back to you as soon as I have some news.

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    We fixed the issue in this commit. The fix will be included in a future Jetpack release.

  11. Walter
    Member
    Posted 5 months ago #

    Just received and completed the Jetpack update... then uninstalled and reinstalled the widget. This fixed the problem of the widget appearing within the border of the previous widget, but it is still not updating to the most recent posts.

  12. Walter
    Member
    Posted 5 months ago #

    This might end up being re-post as my earlier one seems to have disappeared. (Now it has appeared, but I don't know how to delete it... sorry for the double post.)

    I received and ran the Jetpack update, then uninstalled and reinstalled the widget.

    This appears to have resolved the issue of the widget appearing within another, but the post list is still not updating--it remains the same list it was a month ago.

  13. This might end up being re-post as my earlier one seems to have disappeared.

    Spam queue. It happens. *Drinks more coffee*

    You can't delete your posts but you can always add another post explaining (as you have).

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    the post list is still not updating--it remains the same list it was a month ago.

    Sorry about that. It seems the old widget status is still cached in your WordPress installation.

    Could you try to deactivate and delete the Jetpack plugin, and then reinstall the plugin from scratch? That should delete your old settings and thus fix the problem.

  15. Walter
    Member
    Posted 5 months ago #

    I deactivated and deleted the Jetpack plugin... and reinstalled from scratch. No change, the old posts are still showing.

    So I decided to try removing the widget, then adding it back.

    It STILL shows the old posts.

    I deactivated the WP Super Cache Plugin.

    It STILL shows the old posts.

  16. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    I'm sorry to hear that. I added a Display Posts widget back to my test site yesterday, polling from wboomsma.com, and it seems to work properly on my end. I'm not sure what's going on on your site.

    Could you try to add a new Display Posts widget, polling posts from a different site, like WPTavern.com? Do you experience similar issues?

  17. Walter
    Member
    Posted 5 months ago #

    I tried adding a new widget to poll from another of my blogs: boomsmaonline.com and received the message "We cannot load blog data at this time."

    I then switched the new widget to poll from WPTavern and received the same message "We cannot load blog data at this time."

    I'm not anxious to try a different theme only because I've got this one where I want it, but I wonder if this could somehow be a theme-related issue... (I'm really guessing because I do not have much understanding of how these things work.)

  18. Lisa Van Ahn
    Member
    Posted 5 months ago #

    Hey there, I'm having a similar issue.
    I wanted to feature posts from another blog I write on at my footer. I added the widget and initially got the 'We cannot load blog data at this time" message. I made some adjustments and got some featured posts but it wasn't updating.

    I recently tried to re set it and got the same 'cannot load blog data' message.

    I haven't been able to get the widget to update to my current posts on this blog to be shown in the footer....ideas?

    http://www.lvafitness.com

    At the bottom third of the page.

  19. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    @Boomsma

    I don't think the issue is caused by your theme, but there might some cached values that don't get cleared, even when deactivating and deleting Jetpack. Could you run the following SQL query on your database, or ask your hosting provider to run it for you?

    https://cloudup.com/cB1wRCiVaR8

    You might have to change the wp_ in wp_options if you use a different database prefix on your site.

    Let me know if it helps.

    @Lisa Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  20. 253david
    Member
    Posted 4 months ago #

    I assume that since my problem is identical that it is OK to post here. The post widget is not updating on my site tronahistory.com or trona-high-alumni.com. I have gone through all the steps listed above with no change. I have not run the SQL query because I do not know how to or understand how explain to my host provider what I need.

  21. 253david
    Member
    Posted 4 months ago #

    The Jetpack version 2.9 released today seems to fix this problem.

  22. 253david
    Member
    Posted 4 months ago #

    I was wrong. The post updated when I installed Jetpack 2.9 but now I get: " We cannot load blog data at this time."

  23. 253david
    Member
    Posted 4 months ago #

    If you ever get this working pleas let me know. For now I am going to remove the widget and forget about it.

  24. Walter
    Member
    Posted 4 months ago #

    @Jeremy... sorry for the delay in replying, things got crazy. You're a little over my head with the SQL query, etc. but I did run the Jetpack update with the result that my most recent posts are now showing. That feels like major progress! Won't know for sure until I post something new to the site being polled... I'll report back as soon as I've done that and checked the results.

  25. Walter
    Member
    Posted 4 months ago #

    @Jeremy... I created a new post on Brain Leaks, then almost immediately visited Abbot Village Press. There was my new post, right at the top of the list! YAY! I think I can declare the widget is working, at least for me!

    Thanks for your patience and determination... and for the fact I didn't have to figure out "SQL queries." :-)

  26. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 4 months ago #

    I think I can declare the widget is working, at least for me!

    Great news!

    @253david Could you try to update to the most recent version of Jetpack? If that doesn't help, Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

Reply

You must log in to post.

About this Plugin

About this Topic