WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Display of thumbnails on page - sudden empty slots in thumbnails listing (5 posts)

  1. fioxyn
    Member
    Posted 1 year ago #

    WordPress up to date? - Yes
    NextGEN up to date? - Yes

    MySQL up to date - Yes
    PHP up to date - Yes
    The mod_rewrite Apache module activated? - Not sure.
    PHP Safe Mode OFF? - Not sure.

    Hi, there seem to be some problems with the display of thumbnails on my page. As you can see from http://bingbian.com.sg/menu-drinks/, there are two sudden empty slots beside the 3rd last item, and the remaining thumbnails are pushed behind. And on http://bingbian.com.sg/menu-fruits/, there is also an empty slot in the middle. It is working fine on http://bingbian.com.sg/menu/.

    May I know what can I do to make the items display correctly?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. smigliorato
    Member
    Posted 1 year ago #

    Thanks for including all of the technical information.

    However, this is an easy CSS fix.

    The way the images are displayed is a quirk of the way the galleries are layed out, and the fact that they don't have a proper CSS height.

    If you wanted to know why it happens, you'll notice that on the rows above the empty ones, there is a caption that is a bit longer than the others. It sticks out and causes problems on the row below it.

    To fix this, you will have to go to Gallery->Styles.

    Look for a line that says:

    /* ----------- Gallery style -------------*/

    Below this is all of the CSS code that you can use to make the gallery look the way you would like.

    I did some testing on the two pages you said you had problems, and I found a setting that worked just right.

    Find this line:

    .ngg-gallery-thumbnail {
        /* There will be some  *
         * styles here already */
        height: 335px; <- Add this line (not including the arrow)
    }

    Let me know if that works for you.

    You can adjust the setting up and down to see what you like best.

    Hitting Control-F5 to refresh after you've saved the file should ensure you see the results right away.

    If you have any caching plugins enable, on the other hand, it might prevent you from seeing the changes right away.

  3. fioxyn
    Member
    Posted 1 year ago #

    It works now. Thanks very much for the solution, and the detailed explanation! :)

  4. fioxyn
    Member
    Posted 1 year ago #

    Oops, forgot to mark this topic as resolved.

  5. smigliorato
    Member
    Posted 1 year ago #

    Awesome, I'm glad to be of assistance.

    Thank you for marking the thread as resolved!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic