WordPress.org

Ready to get started?Download WordPress

Forums

Display name publicly as: <Username> - NOT Full name! (5 posts)

  1. giannis1
    Member
    Posted 6 years ago #

    Hi,

    When new users are registered to the WordPress are shown “Full Name” in the "Display name publicly as:". How can I make ALL users shown with their "username" by default in the "Display name publicly as:" instead of "Full Name"

    Thank you very much

    John

  2. MichaelH
    Member
    Posted 6 years ago #

    That would require modifying the core file, wp-admin/profile.php, and rearranging the line around line 57 in that file.

    Remember to backup that file before beginning and note you will need to 'retrofit' that change when you perform subsequent WordPress upgrades.

  3. giannis1
    Member
    Posted 6 years ago #

    I've rearranged the line 57 to "user_login" but still again it shows "First Name & Last Name"...

    Any suggestion / help?

    Thanks

  4. MichaelH
    Member
    Posted 6 years ago #

    This is what I used for lines 57 to 62

    <p><label><?php _e('Display name publicly as:') ?> <br />
    <select name="user_login" id="display_name">
    <option value="<?php echo $profileuser->user_login ?>"><?php echo $profileuser->user_login ?></option>
    <option value="<?php echo $profileuser->display_name; ?>"><?php echo $profileuser->display_name; ?></option>
    <option value="<?php echo $profileuser->nickname ?>"><?php echo $profileuser->nickname ?></option>
    <?php if ( !empty( $profileuser->first_name ) ) : ?>
  5. simonmay
    Member
    Posted 6 years ago #

    I have the opposite problem -- my default "display name publicly as" setting is to "username", but I want the default setting to be "Firstname Lastname".

    Any suggestions?

Topic Closed

This topic has been closed to new replies.

About this Topic