WordPress.org

Ready to get started?Download WordPress

Forums

Business Directory Plugin
[resolved] display error (5 posts)

  1. eonelson
    Member
    Posted 7 months ago #

    I have a minor display error on my directory display. I have used firebug to determine the element that needs to be fixed. I have created a custom style css file under wp-content/plugins. However, I am not exactly sure how to make the url image disappear.

    1. Website: http://plant-resources.biz the display error shows on the ad displays by having in image url show in the description area.

    2. the element that needs to be fixed: <div class="field-value wpbdp-field-businessdescription content "> It is currently "url(images/content_topbg.gif) repeat-x top;
    border-top: 2px solid #efefef;"

    This is what I tried: .field-value wpbdp-field-businessdescription content {background-image: none;} I tried a couple of variations, but none of them worked.

    What am I not coding correctly? Thanks so much.

    http://wordpress.org/plugins/business-directory-plugin/

  2. businessdirectoryplugin
    Member
    Plugin Author

    Posted 7 months ago #

    Hi eonelson,

    First, have you correctly installed a custom CSS file to override the CSS used by BD? Here is an article about how to use custom CSS with Business Directory in a way that doesn't get overwritten on upgrade of BD: http://businessdirectoryplugin.com/support-forum/faq/how-to-use-custom-styles-with-bd-2-1/

    Once you have that file in the right place with the right name, you can verify that things are working by overriding something in there and it should take effect. If it's not, double-check your naming and location.

    If that's not working, then report back and we'll go from there.

  3. eonelson
    Member
    Posted 7 months ago #

    Thanks for your reply. I created the following file: wpbdp_custom_style.css and located it in: Plantresources: wp-content: plugins as was instructed in the article. I'm not sure how to verify it because I don't know how to code what I need to do --

    If you check the page as linked to here you will see that there is a gray bar in the center of the listing. I used firebug to see how it is coded (see first message) I don't know how to add the code to the custom style folder to remove it. I'm not great at coding so this is where I need the help.

    Thanks.

  4. eonelson
    Member
    Posted 7 months ago #

    Update: I finally got it. I had it in the right place but couldn't and could see my new coding in firebug but couldn't figure out how to get it to over ride the initial coding. When I used !important with the new coding it worked.

    Perseverance and reading lots of help chats I find on line finally made things click.

    Thanks.

  5. businessdirectoryplugin
    Member
    Plugin Author

    Posted 7 months ago #

    Hi eonelson,

    Glad you got it! Yes, the !important tag is necessary sometimes depending on how your theme styles certain elements. We try to avoid using it ourselves as it can't be overridden which is the whole point of the CSS override file. :)

Reply

You must log in to post.

About this Plugin

About this Topic