WordPress.org

Ready to get started?Download WordPress

Forums

Discussion settings keep changing (7 posts)

  1. GregK
    Member
    Posted 3 years ago #

    From time to time my discussion settings spontaneously change on me -- either to require the user to be signed in, or to require me to approve every post.

    Any idea why this might be happening and how I might fix it?

    Thanks,

    Greg

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. GregK
    Member
    Posted 3 years ago #

    Unfortunately the problem only shows up every several weeks, so the experiment would take a really long time.

  4. radiohelmet
    Member
    Posted 3 years ago #

    this same thing is happening on our blog. I keep having to go into the site and uncheck the box in "Discussion Settings" so that it doesn't require people to sign-up or log in.

    Did you every find the root of this problem?

  5. GregK
    Member
    Posted 3 years ago #

    No, I have not.

    I suspect it's from the flurry of WordPress updates that have been coming out recently.

    Next time I get an update I will check all the settings.

  6. radiohelmet
    Member
    Posted 3 years ago #

    i think i have the answer, based on this email from our hosting service:

    We have noticed a large amount of comment notification spam originating from your account, which indicates that your blog is being abused by spammers and resulting in a large number of emails being sent from your account. Abuse in this manner can lead to several issues including an increased consumption of CPU and spam complaints. In order to stop the large influx of spam notifications, we have changed two settings in WordPress-admin. Under Settings -> Discussion, we unchecked the box that says 'E-mail me whenever Anyone posts a comment' and checked the box 'Users must be registered and logged in to comment'.

    If you require either of these two settings to be changed, please use these additional suggestions to help combat spam posts to your blog

    1. Configure Akismet

    This plugin comes with wordpress by default and can be used to to stop spam comments to your blog.

    2. Install reCAPTCHA

    http://wordpress.org/extend/plugins/wp-recaptcha/

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    @radiohelmet

    Akismet is vital and necessary if you will have open comments.

    In combination with that:
    http://wordpress.org/extend/plugins/cookies-for-comments/
    Is a life saver, I get almost zero spam since turning on CFC

Topic Closed

This topic has been closed to new replies.

About this Topic