WordPress.org

Ready to get started?Download WordPress

Forums

Disappearing Rich Visual Editor (24 posts)

  1. Xof999
    Member
    Posted 7 years ago #

    I've just had a strange experience on one of my blogs. I'm using Firefox 1.5.0.7 on the Macintosh. On one blog, I no longer get the rich visual editor on the Write Post and Write Page sections. All of the appropriate "Use Rich Visual Editor" boxes are checked on.

    This isn't directly browser-related, as another WP blog does show the rich visual editor, and the problem blog used to (and no config changes since it used to).

    Any thoughts? Thanks in advance

  2. drmike
    Member
    Posted 7 years ago #

    Still might be browser related as it's two different sites. Have you done any upgrading lately? Have you tried clearing your browser's cache and doing a forced reload of the page?

  3. Xof999
    Member
    Posted 7 years ago #

    Yes to both, and no change. This happened literally overnight, with no changes to the blog software or the browser. Very odd!

  4. erniew
    Member
    Posted 7 years ago #

    Sure this seems to be browser related. I have exactly the same problem when using FireFox 2. But IE6 works fine.

    I've only noticed it in WP 2.1.1 and later. I've checked with the default theme, and the problem persists. It's beyond me to analyze the reason.

    This is like some glitch in the WordPress Core, so I really hope that the problem is addressed by the Worpress team!

    /EGW

  5. mattnlisa
    Member
    Posted 7 years ago #

    Me too...

    I have installed the latest version of wordpress (2.1.3), running it with the default theme and all plug-ins turned off.

    Under Windows XP Pro and Firefox v. 2.0.0.3, Opera v. 9.10, and Internet Explorer v. 7.0 the "Rich Visual Editor" is gone.

  6. ovationfinancial
    Member
    Posted 7 years ago #

    Same here! What's going on!

  7. stricha
    Member
    Posted 7 years ago #

    I'm having the same problem. I haven't changed any settings, but I suddenly don't get a visual or code view options.

  8. lexhair
    Member
    Posted 7 years ago #

    I had an odd experience. TinyMCE wasn't loading on my Mac using Firefox 1.5.x and 10.3.9. I drafted a post saved and continued editing and all of a sudden, the visual editor appeared. I tried to replicate that and failed. I use an older version of tinyMCE with another application and it loaded fine using Firefox on the same Mac. I went home and tried Firefox on my Intel Mac running the latest 10.4.x system without the visual editor loading. Camino 1.0x also didn't load the visual editor.

    I tried the same thing using Firefox 2.0.3 on my Dell and never saw the visual editor. However, IE 7 loads the visual editor just fine.

    I'm thinking this may be more of a tinyMCE problem than a wordpress problem.

  9. lexhair
    Member
    Posted 7 years ago #

    If you are running the my page order plugin, get the updated version. There was a bug in it that broke the visual editor.

  10. congthinh
    Member
    Posted 7 years ago #

    Huhu!The same to me.
    Try to view code (edit if it is needfull) but :((

    I've use SubDreamer before, it includes TinyMCE Editor so #1. I try to insert Tiny in my Editor pages, but .... so sad.
    Everybody help me.

  11. P. Chandra
    Member
    Posted 7 years ago #

    I recently upgraded to WP 2.2.
    On the post write/edit screen when I switch from "Visual" to "Code", the text formatting buttons disappear. Then I cannot switch back to Visual mode. When I "Save and Continue Editing", I again get the buttons back in Visual Mode. Switch to "Code" and problem recurs.
    [Using Windows XP SP2, On both IE7 and Firefox 2.0.0.3]

  12. isolde100
    Member
    Posted 7 years ago #

    Pchere, I also just upgraded to WP 2.2 and am on a Mac using Firefox 2.0.0.3 and I can't switch to Visual mode anymore. All I get is the code mode. The quicktag buttons are gone.

  13. isolde100
    Member
    Posted 7 years ago #

    OK, I fixed the disappearing Rich Visual Editor problem by deactivating a plugin called Secure and Accessible PHP contact form (v.2.0WP B20070414), now everything is working again. I see the Visual Editor and the quicktags.

    My suggestion: deactivate each plugin and test your site. See which one is getting in the way.

  14. robburke
    Member
    Posted 7 years ago #

    I disabled all plugins and it didn't help; this is affecting Firefox and IE7 on 2 computers.

  15. ganzua
    Member
    Posted 7 years ago #

    It happened to me twice. You de-activate all plugins and then re-activate and you recover the editor till next disappearance.

  16. bobsie
    Member
    Posted 7 years ago #

    I'm also getting this on WP 2.2, using Firefox 1.5.0.11

    I tried deactivating and reactivating all plugins as suggested but to no avail.

    (Btw to clarify, my editor is not just stuck in HTML-edit mode. The line break tags aren't visible, for example, but the bold and italic text formating tags, url tags etc, are visible as text. So it really is just stuck in a regular plain text mode rather than either rich-text or HTML-text.)

  17. StrangeAttractor
    Member
    Posted 7 years ago #

    In my particular case, the cause definitely seems to be the MyPageOrder plugin (2.2), even though this problem is supposedly fixed. When it's disabled, the visual editor works, when it's activated it doesn't. This is true regardless of what other plugins are activated.

    I'm using Firefox, btw, and WP 2.2.

    I'll post again if I find a solution.

  18. timcourtney
    Member
    Posted 7 years ago #

    Any progress on this? I'm using Firefox 2.0.0.4 on MacOS X 10.4.9. The visual mode just broke on me the other day, and it's a real PITA to blog now.

  19. lexhair
    Member
    Posted 7 years ago #

    Check your plugins folder. If you've got a file named index.php, delete it.

  20. timcourtney
    Member
    Posted 7 years ago #

    I have a hello.php file in my plugins folder. Should I delete that?

    I notice that the visual editor still works on my company blog, which we just set up maybe a month ago. My personal one though now it's broken...

  21. Chris_K
    Member
    Posted 7 years ago #

    you visited Users -> Your Profile and checked the top box?

  22. timcourtney
    Member
    Posted 7 years ago #

    Yep, it's checked.

  23. sstignei
    Member
    Posted 6 years ago #

    I found a solution. Visit Users -> Your Profile and UN-check the box. Weird, but it works.

  24. atanone
    Member
    Posted 6 years ago #

    I got the same problem. After seeing sstignei's posting above, I went to the tab Users -> Your Profile. Yes, there is a box saying " Use the visual editor when writing". It was unchecked when I updated my profile last night. I check the box and voilaaaaaaaaa, it works! Thank you sstignei.

Topic Closed

This topic has been closed to new replies.

About this Topic