WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] disallow comments on pages (not posts) (9 posts)

  1. palespectre
    Member
    Posted 3 years ago #

    Hello!

    I would like to ask for help with regards to disallowing comments on my Pages (not posts). These are static links on my site, and I would really prefer for them to not have any comments. I am using the emptiness theme and i tried to search for an answer here and copied some codes to disallow it, but it seems to ruin the entire page. (or i must be doing somethjing wrong). would appreciate the help.

    i also wish wordpress just had an easy option on the dashboard, it's kinda basic isnt it?

  2. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    i also wish wordpress just had an easy option on the dashboard, it's kinda basic isnt it?

    they do - in the 'edit page' page in the dashboard, scroll down below the text editor and the custom fields to get to 'discussion' with options to tick.

    if you don't have these option areas, click on 'screen option' near the top right of the 'edit page' page to reveal an array of options to tick.
    tick at least the 'discussions' option.

    if you want to remove all traces of comments in the pages, you probably need to edit page.php of your theme files.
    then look for 'comments_template();' and remove this with the coresponding html tags.

    make backup copies before editing.

  3. palespectre
    Member
    Posted 3 years ago #

    hej there..

    the ones on the discussion options only disallows comments on posts, i don't want to do that.
    i tried the screen options thing but it only seems to remove the comments on the screen/dashboard view of the pages, but doesnt remove the comments on the pages itself.

    my template is a bit odd, there is no page.php, the editable phps are the following, comments, footer, header, main index template, sidebar, theme functions,

    the comments.php seem to refer to comments on posts though. :( would you know which i can perhaps try editing?

    thank you so much for you input/suggestion.

  4. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    there is the 'discussion' panel under 'settings', but there are also tickboxes under the page 'edit page' which you may need to activate through 'screen options' first.
    http://img853.imageshack.us/i/pagediscussion.jpg/

    have you checked this as well?

  5. palespectre
    Member
    Posted 3 years ago #

    hello, thank you for your help... i see now that we have a different Discussion options. it must be the theme that I chose that doesnt have the option to remove comments on pages.

    here is how my discussion settings look..

    http://codex.wordpress.org/images/thumb/5/55/options-discussion1.png/640px-options-discussion1.png

    i didnt even know settings varied per theme.. :/

  6. Roy
    Member
    Posted 3 years ago #

    You haven an old WP. You can turn off comments for each individual page like described above. Alternally, you can take out the comments option from the page.php of your theme. That's a bit drastic though.

  7. palespectre
    Member
    Posted 3 years ago #

    it says the version i am using is 3.1.

    this is so confusing. thank you for helping and letting me know!

  8. Roy
    Member
    Posted 3 years ago #

    My bad, sorry, I thought the screen looked different.
    There's two ways for you.
    1) Go to the page.php of your theme and delete this:
    <?php comments_template(); ?>

    2) Less drastically, go to a page and edit it. Scroll down to the 'discussion' settings and uncheck 'allow comments'. You have to do this per page.

  9. palespectre
    Member
    Posted 3 years ago #

    Thank you alchymyth and Roy.

    The problem is solved now! I'm sorry i bothered you both, I had to check every screen option thing and finally found it, Thank you both! I was looking at the wrong pages.

    Really appreciate it. :)

Topic Closed

This topic has been closed to new replies.

About this Topic