WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Feather
[resolved] Disabling the social sharing buttons on a specific post (11 posts)

  1. JeffreyRomano
    Member
    Posted 11 months ago #

    Hi I'd like to disable the social sharing buttons on my first blog post which acts as a sort of 'sticky post' on my homepage.

    Any help on this?

    Nice work on the plugin.

    http://wordpress.org/extend/plugins/social-media-feather/

  2. Synved
    Member
    Plugin Author

    Posted 11 months ago #

    Yes this is possible. It's a bit hidden but it's actually mentioned in the settings.

    You can set custom fields on post/pages of synved_social_exclude to yes to exclude those posts from being automatically appended of all social icons.

    Alternatively you can use synved_social_exclude_share and synved_social_exclude_follow to respectively disable appending only sharing or following buttons.

  3. jo1st
    Member
    Posted 8 months ago #

    I'm so sorry. I'm really confused. I can't find that option and I really don't know where I can enter those variables to exclude the icons from a page or post. can you help me??

  4. jo1st
    Member
    Posted 8 months ago #

    I'm not sure why this was set as resolved. I asked some help and I was completely ignored.

  5. Synved
    Member
    Plugin Author

    Posted 8 months ago #

    The Custom Fields editor can be accessed in your Edit Post/Page pages, at the top right of the page there's a label that says "Screen Options". If you click on it it will show a series of checkboxes, just check the one that says "Custom Fields", then go to the Custom Fields box and add one as described above.

    By the way the post was set as resolved months ago when the question was originally asked, after no further replies were provided.

  6. jo1st
    Member
    Posted 8 months ago #

    thank you very much

  7. jo1st
    Member
    Posted 8 months ago #

    Hello there. Sorry to reopen this but after I placed the code on 2 pages this started from the CFS/LFD on the dedicated server.

    6 emails every hours warning about the plugin

    lfd: Suspicious File Alert

    Time: Fri Aug 2 09:05:33 2013 +0900
    File: /tmp/1375343331/social-media-feather/synved-option/addons/option-type-addon/option-type-addon.php
    Reason: Script, file extension
    Owner: *********** (32004:32006)
    Action: No action taken

    Time: Fri Aug 2 09:05:33 2013 +0900
    File: /tmp/1375343331/social-media-feather/synved-option/addons/option-type-addon/addon-handle.php
    Reason: Script, file extension
    Owner: ************** (32004:32006)
    Action: No action taken

    Time: Fri Aug 2 09:05:33 2013 +0900
    File: /tmp/1375343331/social-media-feather/synved-option/addons/option-type-addon/addon-render.php
    Reason: Script, file extension
    Owner: ************ (32004:32006)
    Action: No action taken

    Time: Fri Aug 2 09:05:33 2013 +0900
    File: /tmp/1375343585/social-media-feather/synved-option/addons/option-type-addon/option-type-addon.php
    Reason: Script, file extension
    Owner: *********** (32004:32006)
    Action: No action taken

  8. Synved
    Member
    Plugin Author

    Posted 8 months ago #

    Those files are part of the regular plugin installation, based on the names.

    Could you please zip up that option-type-addon folder and place it somewhere where I can download it and check its contents to ensure they've not been infected with malware in your install?

  9. jo1st
    Member
    Posted 8 months ago #

    hey there. before your reply I uninstalled the plug in and those files were still creating the warning so I went in and deleted the whole thing. Of course I really wanted to use your plugin. I will try to install again and see. if that happens again I will get you the folders to inspect. thank you

  10. snaylor34
    Member
    Posted 1 month ago #

    I used this advice and it seemed to work, but a few weeks later I checked the page and now "synved_social_exclude: yes" is actually being displayed on the page. I am fairly new to WordPress, am I missing an obvious fix here?

    Thanks.

  11. Synved
    Member
    Plugin Author

    Posted 1 month ago #

    The synved_social_exclude custom fields only work for automatically appended icons, are you sure you are not using widgets or shortcodes to display those icons?

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.