WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
[resolved] ...disabled for security reasons.... (6 posts)

  1. csborgman
    Member
    Posted 1 year ago #

    When I network activate I ge this warning:

    Warning: ini_set() has been disabled for security reasons in /home/golive/public_html/wp.golivetools.com/wp-content/plugins/background-manager/vendor/Twig/lib/Twig/Autoloader.php on line 25

    I'm using Catalyst/Dynamik theme.

    Any suggestions?

    http://wordpress.org/extend/plugins/background-manager/

  2. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    This is due to the function "ini_set()" being disabled on your web server (or by your web hosting provider). You can safely ignore this warning, which should not show if WP_DEBUG is set to false in the wp_config.php file.

  3. csborgman
    Member
    Posted 1 year ago #

    Looks like it is set to false in wp_config.php file:

    define('WP_DEBUG', false);

    Please advise. Thank you!

  4. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    If you are allowed to set your own php.ini settings by your web host, then you'd need to set display_errors = 0.

    This is normally taken care of by WordPress using the WP_DEBUG directive , but is also dependent on the ability to use ini_set() so in your case does not work.

    The alternative is to manually modify the file wp-content/plugins/background-manager/vendor/Twig/lib/Twig/Autoloader.php and on line 25, add an @ sign before ini_set as following:

    @ini_set('unserialize_callback_func', 'spl_autoload_call');
  5. csborgman
    Member
    Posted 1 year ago #

    OK, works perfect! I do have access to the php.ini file and made the change. Thank you!

  6. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Glad to hear it has been resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic