WordPress.org

Ready to get started?Download WordPress

Forums

Disable self-pingback (7 posts)

  1. Varsity
    Member
    Posted 8 years ago #

    Whenever I link to my own blog in a post, I get a pingback. This isn't very useful when it's the same site! Is there any way to disable this thing (like no-to-me does for e-mails)?

  2. mickej
    Member
    Posted 8 years ago #

    I would also like to know how to disable it.

    Why is it even enabled default? Very unnecessary?

  3. Truth
    Member
    Posted 8 years ago #

    I'm wondering the same thing.

  4. moshu
    Member
    Posted 8 years ago #

    Use relative path (instead of absolute) and you'll be fine.

  5. mickej
    Member
    Posted 8 years ago #

    I tried an ugly solution to the "problem" (I don't want my own post to become comments in my other posts that i link to):

    I just added my blogs TITLE to the exclude list under Settings -> Discussion

    I.e.:

    whatever.com - my blog

    Hopefully no one writes exactly that in their comments. ;)

    Seem to work fine. Is it a VERY bad solution?

  6. alastc
    Member
    Posted 7 years ago #

    Apparently using an absolute path without the domain (e.g. "/folder/file.html") prevents it.

    What would be great would be something that removed the domain from any that matched my own, for links and assets (i.e. images).

    I use a development environment that closely matched the live server, and it runs with a slightly different domain. Transfering sites from one place to another would be much easier if you could automatically use absolute URLs without the domain.

  7. Michael Adams (mdawaffe)
    Member
    Posted 7 years ago #

    To stop self pinging, just use this plugin: No Self Pings

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags