WordPress.org

Ready to get started?Download WordPress

Forums

Disable Parent Menu Link
[resolved] Disable Parent Menu Link: Rolling over parent links deactivates text-transform (9 posts)

  1. tracyberna
    Member
    Posted 2 years ago #

    I'm having a really odd problem. Kapil Chugh, I hope you're reading.

    I installed Disable Parent Menu Link and it works fine, except that I'm using "text-transform: uppercase" on the menu. When DPML is active, as soon as you roll over a link that has child links, once your cursor moves off it the text-transform goes away and leaves the link text in lowercase. I can't figure out WHY this would happen.

    Unfortunately, this site has a bunch of stuff affecting the menu. I'm using a theme called Atahualpa, which has a built-in choice to make a menu out of categories. However, the client wanted some pages in the menu as well, so I'm using Custom Menus as well as a plugin called "Add Descendants As Submenu Items" which does just what it says on the can. So adding your plugin is just one more complication - I don't know if you can get to the bottom of this with all that other stuff, but it would sure be nice. Thanks in advance, and let me know if there's any other info you need.

    http://wordpress.org/extend/plugins/disable-parent-menu-link/

  2. Kapil Chugh
    Member
    Plugin Contributor

    Posted 2 years ago #

    Can you please share URL of your site?

  3. tracyberna
    Member
    Posted 2 years ago #

    http://www.lappg.com. I don't have the plugin activated just now. Does it need to be for you to look into what's wrong?

  4. Kapil Chugh
    Member
    Plugin Contributor

    Posted 2 years ago #

    Yes, it would be better, if you could please activate it.

  5. tracyberna
    Member
    Posted 2 years ago #

    It is now activated. :)

  6. Kapil Chugh
    Member
    Plugin Contributor

    Posted 2 years ago #

    Okay, thanks.

    Let me check.

  7. Kapil Chugh
    Member
    Plugin Contributor

    Posted 2 years ago #

    Got it :)

    Please search with this class in CSS ul.rMenu li a:active and you need to replace it with ul.rMenu li a

  8. tracyberna
    Member
    Posted 2 years ago #

    I wasn't sure what you meant at first, but I took out "active" out of that bit of CSS and it works! Thank you so much! :D

  9. Kapil Chugh
    Member
    Plugin Contributor

    Posted 2 years ago #

    Gr8!! :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic