WordPress.org

Ready to get started?Download WordPress

Forums

Disable Notify me of new posts by email (11 posts)

  1. TCJohnson71
    Member
    Posted 2 years ago #

    I help a buddy out with his personal blog. Recently he upgraded to version 3.2.1 and now, when a user goes to view an attachment, there appears two additional options below the usual comments form:

    Notify me of follow-up comments by email.
    Notify me of new posts by email.

    I did some research and it would seem you are to disable this via Settings/Discussion, but those options are not there. He would like to have these options removed on the pages that display attachments such as images. Here is an example:

    http://www.bradmcdonalddesign.com/?attachment_id=7626

    How would I go about accomplishing this?

    Thanks,
    TC

  2. Normally this kind of notification is there once a plugin is in use. I would look at the activated plugins and see if any notification plugins are being used?

  3. TCJohnson71
    Member
    Posted 2 years ago #

    He only has two plugins enabled: SEO All in One and JetPack. Could it be a Jetpack setting? What PHP file in the core actually handles the display of attachments?

  4. pascoedj
    Member
    Posted 2 years ago #

    I see this one my own hosted site as well. It seems it has snuck in with jetpack somehow. I have my own plugins for subscribe to comments and subscribe to new posts - but now have this unwanted extra one "Notify me of new posts by email." which attached itself to the comment form.

    Haven't worked out yet how to turn it off!

  5. pascoedj
    Member
    Posted 2 years ago #

    solution is here
    http://wordpress.org/support/topic/errant-checkboxes?replies=4#post-2504334
    need to update your style.css to hide the option

  6. It's a part of Jetpack.

    Turn off Subscriptions if you don't want it.

  7. pascoedj
    Member
    Posted 2 years ago #

    I never enabled subscriptions via Jetpack.

    You need to drag and drop a widget to enable subscriptions which I haven't done.

    It looks like a bug to me.

  8. Did you upgrade Jetpack?

    If so, you had Subscriptions installed and, yes, it's turned on by default. So unless you know you turned it OFF...

  9. Rajesh Namase
    Member
    Posted 2 years ago #

    In in style.css at the end add:

    #subscribe-blog-label, #subscribe_blog {
       display: none;
    }

    Code will disable "Notify me of new posts by email" option.

  10. kirkward
    Member
    Posted 2 years ago #

    Is there any option to disable it on a post or category basis?

  11. Rajesh Namase
    Member
    Posted 1 year ago #

    Now JetPack provided option to disable it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.