WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Disable nofollow attribute (14 posts)

  1. vagabond_uk
    Member
    Posted 4 years ago #

    Is there a way to disable nofollow attribute in the body of a post?

    In the blog posts that I write I would like to link out to other pages that are followable by search engine spiders. However, I want to retain the nofollow attribute for comments to prevent comment spam.

    Is there a way to do this in the admin panel, or a plugin that can do this?

    Thanks.

  2. cryonics
    Member
    Posted 4 years ago #

    Never seen nofollow in my posts, surely, this come from some plugin...

  3. mrmist
    Forum Janitor
    Posted 4 years ago #

    There are various "dofollow" plugins that will override nofollows. Do a google or plugin search.

  4. vagabond_uk
    Member
    Posted 4 years ago #

    No, i believe WP 2.8+ automatically nofollows links by default

  5. vagabond_uk
    Member
    Posted 4 years ago #

    @mrmist Thanks, but most of the plugins i've found remove the nofollow from comments, not from the post itself.

    I want to do the reverse and remove the nofollow from the post, not the comments.

  6. cryonics
    Member
    Posted 4 years ago #

    I have made a try, no "nofollow" for me with 2.8.2 in posts.

    It would be stupid to add a such feature.

  7. syncbox
    Member
    Posted 4 years ago #

    It's a setting in your admin in 2.8x to select the follow/nofollow option for all or just not search engines. (Privacy).

    WordPress used to use rel="nofollow" for comment links, not sure if it still does, but there are many comment spam plugins you can use, too.

    Here's a site with a LOT Of useful information that may have something you can use.

    http://www.instantshift.com/2009/06/15/22-mixed-quality-wordpress-hacks/

  8. mrmist
    Forum Janitor
    Posted 4 years ago #

    I have to agree - Normal posts that I make which have links in them do not have "nofollow". Are you using the default theme? If you switch to a different theme do your links still have nofollow?

  9. vagabond_uk
    Member
    Posted 4 years ago #

    Thanks for the replies. I've done some playing around but can find no option in 2.8x privacy for this. On my installation there is only the option to make the blog searchable or invisible to search engines.

    However, on another subdomain I installed an older version of WP (2.7) and then upgraded from my host cpanel via Fantastico to 2.8.2. Guess what? No nofollows...

    Seems to me to only be a problem if you do a completely clean install of WP 2.8+

    So i guess the answer to my question is to install an older version of WordPress and then upgrade.

  10. mrmist
    Forum Janitor
    Posted 4 years ago #

    You shouldn't have to. Fresh 2.8.2 installs for me do not add nofollows. I think you must be running some theme or plugin that is changing the links.

  11. vagabond_uk
    Member
    Posted 4 years ago #

    I'm afraid not. This is happening from a completely fresh install of 2.8.2 via my host's Fantastico installer with only the default WordPress theme.

    I'm going to install 2.8.2 via FTP from my own machine, rather than via Fantastico to see what happens.

  12. vagabond_uk
    Member
    Posted 4 years ago #

    Getting really fed up with this now. Even from a clean install of 2.8.2 from a downloaded version I'm still getting all links (internal & ecternal) nofollowed.

    Its being caused by the robots meta tag (which appears in my source code), but I haven't added in a robots meta tag into any WP page. So I can't work out how to remove or over-ride it.

  13. elgunwp
    Member
    Posted 4 years ago #

    Vagabond:

    In latest versions of WP there is no nofollow tag at all. Actually, I wanted to add one that makes nofollows for my posts but word has stopped adding nofollows automatically. We have to add it manually. Be sure with your hosting company with one click installation.

    I am upset that they have depappreciated nofollow tag automaitcally.

    I hope you solved the problem. Please send your link and let me check it if you prefer so.

  14. chitown
    Member
    Posted 4 years ago #

    @Vagabond,

    I had this same issue with my 2.8.6 install. I thought Blog Visibility setting in Privacy would do it and it actually did.

    The problem is that the nofollows in existing posts did not get removed. All new posts did not have nofollow, but in all the old posts I had to go into the HTML view for each post and remove the nofollow. A royal pain, but luckily my blog is relatively new.

    Good to go now, but it was annoying.

Topic Closed

This topic has been closed to new replies.

About this Topic