WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] disable new admin bar (5 posts)

  1. sophieanne
    Member
    Posted 3 years ago #

    I just upgraded to 3.0.5 and there's a new admin bar on every page of my live site. It does not render correctly and is driving me crazy. Does go away when I log out but I really need to turn it off.

    I found a plugin, but I really don't want to install yet another plugin to disable this. Thanks.

  2. rfair404
    Member
    Posted 3 years ago #

    you can add this to theme functions.php

    /* Disable the Admin Bar. */
    add_filter( 'show_admin_bar', '__return_false' );
    
    /* Remove the Admin Bar preference in user profile */
    remove_action( 'personal_options', '_admin_bar_preferences' );
  3. b-rad
    Member
    Posted 3 years ago #

    Go to your profile and you should see the option "Show Admin Bar". You have two checkbox choices, "when viewing site" and "in dashboard".

  4. sophieanne
    Member
    Posted 3 years ago #

    Oh thank goodness that worked! Thanks so much.

  5. rhwheels
    Member
    Posted 3 years ago #

    Thanks a ton, b-rad. It worked.

    Here's a screenshot for those who work better with a visual aid.

Topic Closed

This topic has been closed to new replies.

About this Topic