WordPress.org

Ready to get started?Download WordPress

Forums

Disable magpie rss cache ? (3 posts)

  1. SimonJ
    Member
    Posted 6 years ago #

    Hello!

    Ok.

    From what I can tell, the rss engine of wordpress cache the result in the wp_options table, in the database.

    Is there a way to disable the cache when I call fetch rss ?

    I tried :

    define('MAGPIE_CACHE_ON', 0);
    define('MAGPIE_CACHE_AGE', 0);

    With no success...

    I have a feed from a wordpress on domain A to display to a wordpress on domain B... It takes forever, the feed doesn't update when I write a new post...

    When I drop the cache fields in the wp_option table, the feed updates in a second... So I figure that if I could disable the cache, I will solve my problem...

    S.

  2. Kapa
    Member
    Posted 6 years ago #

    Hi,
    You can actually change the timing of the cache :

    Go to wp-includes/rss.php line 586

    instead of 60*60 corresponding to one hour put e.g. 1*3 to get almost immediate refresh.
    Yours, Oscar
    blog.paradiSEO.fr

  3. SimonJ
    Member
    Posted 6 years ago #

    Thanks Kapa. I'll try it in future installations.

    But right now, on the project I actually work on, I just decided to get rid of the rss WP stuff and use a standalone magpierss script. I feel that I have more control like this.

    Thanks again

    S.

Topic Closed

This topic has been closed to new replies.

About this Topic