WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Disable Comments for Page Option (37 posts)

  1. That suggestion is already in trac: http://core.trac.wordpress.org/ticket/9839

    Most devs will say 'If you want to turn off comments for all your pages, edit your theme so it doesn't call the comments loop' though.

  2. Dimitri Vorontzov
    Member
    Posted 3 years ago #

    I sure hope most devs are not that lazy.

    By the way, that must be a wrong ticket.

    Looks like they were discussing Media items, rather than pages, and the discussion dealt with WordPress 2.8, and took place a couple of years ago.

  3. It's still not been patched.

    You could make your own trac ticket (which is btw how you get in touch with the devs) and suggest it there.

  4. Dimitri Vorontzov
    Member
    Posted 3 years ago #

    Great idea! Thank you Ipstenu.

    I never realized mere mortals can create their own trac tickets.

    It's done: http://core.trac.wordpress.org/ticket/17478

  5. hthr
    Member
    Posted 3 years ago #

    I cannot tell you how RELIEVED I am to FINALLY find this discussion!!!

    Weeks of online searches, and after deleted thousands of comments on what I was trying to present as a professional business web site to the public, I can turn off the comments!

    dimitri, you are my hero. thank you thank you thank you. To have someone with enough patience to guide the discussion in the direction it needed to go ("it's so simple, duh!" ..."no, it isn't...").
    Praise the Google gods and pass the tax rebate, the comments are finally turned off on my website.

    One little nit picky thing I like to harp on now that the mess has been cleaned up-
    Why do all the themes for WordPress automatically download as blog pages?? If I wanted a blog page, I would have set one up! WordPress, I love you, but I don't need a thousand themes of blog pages. I need some ideas on how to present a professional online store, thanks.

    and thanks for all your help on this problem for me. Glad to see I wasn't the only struggling!

  6. Frank Odds
    Member
    Posted 2 years ago #

    Phew! I was so pleased to find this thread. I'm a complete newbie to websites, WordPress and the rest. Am using the Twenty Eleven theme on Dreamhost.
    My site is not a blog site at all. One of its main features is pages with photo galleries. At the foot of every single photograph in a gallery the words "Comments are closed" appears, totally without relevance. How do I get rid of these words? Following your recipes for pages above doesn't seem to affect the photo galleries at all.
    Might it be a thought for WordPress, with its own showcase themes like twenty eleven, to offer installs with two sets of default options activated? One for blogs and one for those of us using the software for non-blog sites?

  7. Frank - You want to do this by editing your theme. Post in the Themes and Templates section, with a link to your site.

Topic Closed

This topic has been closed to new replies.

About this Topic