WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
DISABLE Cache (10 posts)

  1. shmk
    Member
    Posted 7 months ago #

    Hello,
    I have a gallery with titles and descriptions on images and every time I update an image title or description the change is not shown on frontend untill I manually clear the cache on Other Options, Miscellaneous screen
    (I'm using a custom template).

    Because I cannot every time I edit an image to manually clear the cache, how can i disable the cache?

    Thanks in advance.

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 7 months ago #

    @shmk - This is not something we see when we use and test the plugin, perhaps you have a caching plugin or a cache enabled on your server that is causing this effect to be seen?

    - Cais.

  3. shmk
    Member
    Posted 7 months ago #

    I have no cache plugins and I don't know if the server has a caching mod (I'm on GoDaddy hosted server, if this could help).

    I've checked that this caching effect doesn't happens on default templates but only on custom templates (I've added a template in my-theme/nggallery/gallery-custom.php).

    I'm recalling the gallery in my homepage using this shortcode:
    echo do_shortcode('[ngg_images gallery_ids="1" display_type="photocrati-nextgen_basic_thumbnails" template="custom"]')

    Tell me if I can send you more infos or I can try something more for debug.

  4. photocrati
    Member
    Plugin Author

    Posted 7 months ago #

    @shmk - You could send us a Bug Report (http://www.nextgen-gallery.com/report-bug/ ... please reference this topic) with your site specifics. We will likely need log in and FTP credentials as well, please include those with the Bug Report, too.

    Thanks!

    - Cais.

  5. PeterBe_SK
    Member
    Posted 6 months ago #

    Hello,

    I just started test nextgen gallery. I uploaded only 3 pictures, this pictures I insert to post with shortcodes [singlepic id=3 w= h= float=none ]. Then I try various settings and look on post preview. Then I look to /wp-content/gallery/gal/dynamic/ and saw 21 (twenty one) cached files. Then I cleared cache.

    I published this post with 3 pictures, clicked on every picture and look to dynamic folder. I saw 3 cached files. I afraid when will be hundreds pictures in gallery what happened with free size on server HDD due to cache files.

    How can disable cache and stop loading files to dynamic folder? Or is it possible set max size of cache?
    I have default settings of NGG and haven’t any caching plugin. Theme is zeeNews.

    Thank you.
    Peter

  6. klogan2
    Member
    Posted 4 months ago #

    I'm having the same issue(s). I'm developing a template, and NextGen caching is making me crazy while I work on the development. I need to clear the cache everytime I upload a revision of the template php pages. Can the cache be disabled during development/gallery editing? Photocrati, you seem to have directed shmk away from this forum,,, did you find an answer & post the solution somewhere OUTSIDE this forum,,where the question was originally posted?

    NextGen V2.0.40, WordPress Version 3.8.1, No caching plugins

    Thanks,
    Kevin Logan

  7. liger
    Member
    Posted 4 months ago #

    Hello there,

    I have same kind of issues. Whatever change I do in the NGGallery codes doesn't update on the frontend. Even I clear and disable the browser cache it takes pain in the ass to have it refreshed..

    I figured out clear image cache in the miscellaneous tag works but I need to push that button every time I do changes in the code..

    How can I fix it? Really annoying.

  8. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @liger - You would be better off starting your own topic and explaining the issue you are having in more detail as it pertains directly to your site.

    Thanks!

    - Cais.

  9. mkluczka
    Member
    Posted 3 months ago #

    For anyone looking for the answer – append ngg_force_update=1 to url

  10. klogan2
    Member
    Posted 3 months ago #

    change the 1 to the site url?

Reply

You must log in to post.

About this Plugin

About this Topic

Tags